summaryrefslogtreecommitdiff
path: root/dev-python/doit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/doit
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/Manifest2
-rw-r--r--dev-python/doit/doit-0.35.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
index f1ababcd77b8..715dee079635 100644
--- a/dev-python/doit/Manifest
+++ b/dev-python/doit/Manifest
@@ -1,3 +1,5 @@
DIST doit-0.34.2.tar.gz 1449767 BLAKE2B c7d81144da99147dbc6bf7d670b6f411879a8080e405866866bc97ae4701d9a47a3d4882db9672e2e36bc8af577ba9632da1fb4ed2c9f87717f719ac1cd53d34 SHA512 24afc8078fef42a446733554c6ab63298ee5bb734381fc2bfc9d623dc98394916a1f89a18bb28e7ef862da8c0449b5cf16d605295e8948a0ea6968a231a1c8e2
+DIST doit-0.35.0.tar.gz 1451502 BLAKE2B db0c1c9245897ca9c4ce4d3f5f43e5f2e5035c36cc4bd15e63d6fb9e69992b5068ca24839a02485680cdc75ba62cb95f139f6fd0ec24c1f26fd4c4b2e4fce27e SHA512 3eb3fc0284c4779db47c56c9e21bda16e31d053214f4a0272c1a26c9fd26bc0de7d00601bb08a79a3d0ed403464e773c03fe93d0fcd9ee59812c396e0f4ed7e6
EBUILD doit-0.34.2.ebuild 1340 BLAKE2B b5b5cf0fa9ad50fa1fae8ace420c6b02f3c486930350eaed8c6acb2d5b855577305df0126bfaa906c104a97a19e65ad2fe8ed60b3b44b803376d6b6f45cb6132 SHA512 b26083148144f940816fc29d7836687e78f1f413e0f662643fc750f3325c1719309139055f0a31facfd7406ca6b266bf8184cb2bed950d50a70054f32f24e213
+EBUILD doit-0.35.0.ebuild 1298 BLAKE2B 246f2ffa4f014927979dcb2630c7392f1720137260c7b5ecd79d107f7b1b29d21cc7a50f97c9e14bb4d50730f507c2a65e2a8bf69cd9b53292ca0ef796136f38 SHA512 ea121ef56d6305f16e067784c13c35b45617efcead0d6420c7e82846a12f389a61e5c9e736bacb2759f66fe059232e74b0395c750fe5ce94a26fec2f4807454c
MISC metadata.xml 568 BLAKE2B add52a6e7986bb88b9dc87d2f03c4ec3716ae7d5e2402556b7a3137b8267ca2cad0ae3324d628f3127afde36513414029c0f567a9683dd9b11b1a287ff5e3a7d SHA512 e772c9ccd8133fd73dcf04733facf60ef7c2f1559b83e5024faeea4d5fd7799c42a28be6c9b8676ea9b6d68969ca5be633320e8cb7dd8d1f0dca35e819eaebc7
diff --git a/dev-python/doit/doit-0.35.0.ebuild b/dev-python/doit/doit-0.35.0.ebuild
new file mode 100644
index 000000000000..23acc79d9cb6
--- /dev/null
+++ b/dev-python/doit/doit-0.35.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="https://pydoit.org/ https://pypi.org/project/doit/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ || (
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND=">=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # test failing due to impact on PATH run in a sandbox
+ tests/test_cmd_strace.py::TestCmdStrace::test_target
+)
+
+src_prepare() {
+ # Replace custom theme with builtin for documentation
+ sed -e '/html_theme/s/press/sphinx_rtd_theme/' -i doc/conf.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp bash_completion_doit ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins zsh_completion_doit _${PN}
+}