summaryrefslogtreecommitdiff
path: root/dev-python/doit/doit-0.32.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/doit/doit-0.32.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/doit/doit-0.32.0.ebuild')
-rw-r--r--dev-python/doit/doit-0.32.0.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/doit/doit-0.32.0.ebuild b/dev-python/doit/doit-0.32.0.ebuild
deleted file mode 100644
index 347f0c06dfe8..000000000000
--- a/dev-python/doit/doit-0.32.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit eutils distutils-r1
-
-DESCRIPTION="Automation tool"
-HOMEPAGE="http://python-doit.sourceforge.net/ https://pypi.org/project/doit/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-DEPEND="test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}] )
-"
-PDEPEND=">=dev-python/doit-py-0.3.0[${PYTHON_USEDEP}]"
-
-# Required for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # Disable test failing due to impact on PATH run in a sandbox
- sed -e s':test_target:_&:' -i tests/test_cmd_strace.py || die
-
- # Test requires connection to an absent database
- sed -e s':testIgnoreAll:_&:' -i tests/test_cmd_ignore.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- local -x TMPDIR="${T}"
- # disable tests where pypy's treatment of some tests' use of a db is incompatible
-
- if [[ "${EPYTHON}" == pypy ]]; then
- sed -e 's:test_remove_all:_&:' -i tests/test_dependency.py || die
- sed -e 's:testForgetAll:_&:' -i tests/test_cmd_forget.py || die
- sed -e 's:test_not_picklable:_&:' \
- -e 's:test_task_not_picklabe_multiprocess:_&:' \
- -i tests/test_runner.py || die
- fi
-
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-src_install() {
- use doc && HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_src_install
-}