summaryrefslogtreecommitdiff
path: root/dev-python/docutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-06 18:54:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-06 18:54:07 +0000
commitcf7a256641d0729742707e68efe5e5ee3895b6c9 (patch)
tree10acbc3170c4b685aea3df6a9e96bb418a586725 /dev-python/docutils
parent56330f065f2b903d9e1b2dffc63719fef5897a45 (diff)
gentoo auto-resync : 06:01:2024 - 18:54:07
Diffstat (limited to 'dev-python/docutils')
-rw-r--r--dev-python/docutils/Manifest2
-rw-r--r--dev-python/docutils/docutils-0.20.1-r1.ebuild10
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/docutils/Manifest b/dev-python/docutils/Manifest
index 87a24fa4f813..ef2e5be6214f 100644
--- a/dev-python/docutils/Manifest
+++ b/dev-python/docutils/Manifest
@@ -2,5 +2,5 @@ AUX docutils-0.19-pygments-2.14.patch 18917 BLAKE2B 889de063bfd6aae39512103c0da0
DIST docutils-0.19.tar.gz 2056383 BLAKE2B 9983a905642de4e81ca118578671b503ddfda4bef1afcc0524de40543e1f9617fd8d768ef467da49d2f01076683400bad6a0fe15f6b5a3a1e202c42b2e34ab1b SHA512 fb904a899f2b6f3c07c5079577bd7c52a3182cb85f6a4149391e523498df15bfa317f0c04095b890beeb3f89c2b444875a2a609d880ac4d7fbc3125e46b37ea5
DIST docutils-0.20.1.tar.gz 2058365 BLAKE2B 73fb8302599ffe57b0840c898b0b2e3ccd39ff9ea6eec2b5d345d02c950e1a8357bd821e62733b0484e82bc30e71d30fab381390b0edaef4375b02bcd9eeeb40 SHA512 a0ddca315d03677003036d6a8052ac96fbd3fcc4508564938ea684d79bedb4d322d83449c7b26e55b19b0aadd6e46ca9ac409bb16279a20f06c70e9c15ef5eb0
EBUILD docutils-0.19.ebuild 1729 BLAKE2B 83518b007ed7f6fe5491ad883c6272ea93ee91a177271bb791f63cda6d5b7048d5b8981a734307f8926e41ffdde6c5bb328b1edc41ade6f2e543a5cb9b65c851 SHA512 120702a6a0d4d495c4f9367e11b6b8190352c007ffa8ce767a9f5284bcd366e462dc7e19427e208b1fa98418785de13d17b9bbe1530091cf7a6307611e0a9573
-EBUILD docutils-0.20.1-r1.ebuild 1716 BLAKE2B 43f85217534e481ffeab883333703746d9b6fa41e0ba4c6f3cdf11564348d088c617f743543319c2c2608481835057e83dc9b65c77dc47c47737c5ce3dab1bd7 SHA512 c1ba28f8d6f542e6885f2f816c229916f25b0fce485ad9d4a03a00543ca7c7d7197832d2ee84dc001fd449386bc7f2cafd30870fbb9a884a4333912c05eb38e6
+EBUILD docutils-0.20.1-r1.ebuild 1853 BLAKE2B b75645393398ab3fa73876eb28df85b3382e9b7800b0a8a7aad0f09519893fa5ad9d095a82a6030bde07eb7200747c73182588e48af5c15159c480672d51bb1c SHA512 ffd798465857662393047ab9ac4a976b0ad0f193eafc4d41f61cd3cc0a2876ad5d82449cda0796d762161a15951d5920b7d79e04d8968cff72767783663ed446
MISC metadata.xml 389 BLAKE2B b586fccb92f88e7f2ee68879bb919298953da9eb629fc1042f5f35b316b59ffcc614f23135fe1ab4af8ba9646bcbc33f194ac74af795094e20d288817b5e227b SHA512 ac8975a27694a2a0efd07c944a769f1a210bbf4a1550f92f0ead3ac2dc9ffb4d82206858f2a8631f751c81fdace88433b9d89f8c3d6af72907e102da5696693f
diff --git a/dev-python/docutils/docutils-0.20.1-r1.ebuild b/dev-python/docutils/docutils-0.20.1-r1.ebuild
index b6e73efa09cc..cca31d549b55 100644
--- a/dev-python/docutils/docutils-0.20.1-r1.ebuild
+++ b/dev-python/docutils/docutils-0.20.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit distutils-r1 pypi
+inherit distutils-r1 optfeature pypi
DESCRIPTION="Python Documentation Utilities (reference reStructuredText impl.)"
HOMEPAGE="
@@ -71,3 +71,9 @@ python_install_all() {
install_txt_doc "${doc}"
done < <(find docs tools -name '*.txt' -print0)
}
+
+pkg_postinst() {
+ optfeature \
+ "auto-detecting the image dimensions when using the 'scale' option" \
+ dev-python/pillow
+}