summaryrefslogtreecommitdiff
path: root/dev-python/docstring-to-markdown
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-05-03 12:56:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-05-03 12:56:24 +0100
commitecfab6c7aa347b8ea9855252de09ddad91a9423b (patch)
tree9a085e15967ba9144b90b46d381faf6fcb056fee /dev-python/docstring-to-markdown
parentc19fd4a8a0e61cf71603721d947f7d15e3bffbc1 (diff)
gentoo auto-resync : 03:05:2025 - 12:56:23
Diffstat (limited to 'dev-python/docstring-to-markdown')
-rw-r--r--dev-python/docstring-to-markdown/Manifest2
-rw-r--r--dev-python/docstring-to-markdown/docstring-to-markdown-0.17.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/docstring-to-markdown/Manifest b/dev-python/docstring-to-markdown/Manifest
index a71faee04ace..906dfa970ce1 100644
--- a/dev-python/docstring-to-markdown/Manifest
+++ b/dev-python/docstring-to-markdown/Manifest
@@ -1,3 +1,5 @@
DIST docstring-to-markdown-0.16.gh.tar.gz 31553 BLAKE2B 66dfaf08ca08d6209bae851ffc15d26bac76ec71c417a4b6094fcf23b863f17cb7abda9c191089aeffe31cee6041803f27de4448feb6918be179561cb3ecfd6c SHA512 4052194a12525071558d859ef23fd33c1c131676f7931ff72891b951d2a7726c1b786639c00be2ff3578bff155cf77d22ddeb03d87dcd782baa337f456a8647f
+DIST docstring-to-markdown-0.17.gh.tar.gz 32692 BLAKE2B 5d209fa68383df7f0c0ab1910caf6c7481e53b5a2848015a03ab95f5aeb4422bd1923365b27dbdb91a641a2884ff27923356541e4c725520fd1481ec46c800c9 SHA512 1b861eb1e92907ce69e2e0b49ecc13e6a5cb4c1c73980b3fe1f6e241b6e11688a96abaf97223932c4a90c451ced8285612b39076303ede891cc33ec4ce38aff0
EBUILD docstring-to-markdown-0.16.ebuild 809 BLAKE2B cebf38d262683527c3850aa03ddba48626f29da28a8e18a677acb4f367b52cb769774b1e8aaa8959e1716f89c181da67161fa1f7919d4bf83f5632193493696b SHA512 2b93a3b03caf59c1be4fb7bcc0ff7c7ba30b356af7e38129af4b0aa81e0a327be8edcc43632fac53e5523936539864541f9c0318d82094e078582565cf4e0e38
+EBUILD docstring-to-markdown-0.17.ebuild 806 BLAKE2B 5f8d8534e85660a89ec6d4c1fa1bf3b4a71dea65be9661c54a736ad029e8a393ab42784a29f227109801f618bf2eb507a045c9c4ec9e27d7fffaa882942ed1b7 SHA512 c0333d7d404078439d4379810232e0d3980e110f9fbebc62e0699346f3b4be0e11dae410cff9d879018b993a841c1bca5e6cb0f4dd0519ae4da546e96db6aea3
MISC metadata.xml 421 BLAKE2B a6bf8b83336e2e1b67af703c3ddc6d68a5ce94a3477902a9f6d7d35f8a5635cad265365820548959ccf861a14c1c24d5bb2fd934a6fc297ca20182b5686c3ec5 SHA512 952b36476833618a51a6c05181213fb8598237157e887fb81369084db327fc360e827ff2393e00f99141efa2256ea0701ca17005ddd337661a6d9e8f81fd3494
diff --git a/dev-python/docstring-to-markdown/docstring-to-markdown-0.17.ebuild b/dev-python/docstring-to-markdown/docstring-to-markdown-0.17.ebuild
new file mode 100644
index 000000000000..a1ade9207965
--- /dev/null
+++ b/dev-python/docstring-to-markdown/docstring-to-markdown-0.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} pypy3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="On the fly conversion of Python docstrings to markdown"
+HOMEPAGE="
+ https://github.com/python-lsp/docstring-to-markdown/
+ https://pypi.org/project/docstring-to-markdown/
+"
+SRC_URI="
+ https://github.com/python-lsp/docstring-to-markdown/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/importlib-metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.6[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}