summaryrefslogtreecommitdiff
path: root/dev-python/docstring-to-markdown
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-22 00:41:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-22 00:41:01 +0000
commit23b767af73549eeb4dd3069e09d0f2fcb88669a8 (patch)
tree7ad731ac748d72a48ae7079bc8fb0718c554d65d /dev-python/docstring-to-markdown
parent3003897133b1bcfe9a241c2708e938903879aee3 (diff)
gentoo auto-resync : 22:03:2023 - 00:41:01
Diffstat (limited to 'dev-python/docstring-to-markdown')
-rw-r--r--dev-python/docstring-to-markdown/Manifest2
-rw-r--r--dev-python/docstring-to-markdown/docstring-to-markdown-0.12.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/docstring-to-markdown/Manifest b/dev-python/docstring-to-markdown/Manifest
index 2673da845b74..57a980ecfea5 100644
--- a/dev-python/docstring-to-markdown/Manifest
+++ b/dev-python/docstring-to-markdown/Manifest
@@ -1,3 +1,5 @@
DIST docstring-to-markdown-0.11.gh.tar.gz 25349 BLAKE2B ea5c5d568146422826075bddc1acfe64ebe9d8c2a1631aae2afc50e99e380b038becc8f589097b329c80287fb2308dc3ce4c898252eb45086a893c74fa7a7aeb SHA512 6f593628f1dc49897359f7366ee7cb380e5f5e68f6cefd16f349eb470df62804c8f20d679484b987dbb33155e2c97ee98c6759e17ebb1ca38499ea5e984baede
+DIST docstring-to-markdown-0.12.gh.tar.gz 25464 BLAKE2B bb5168b9ddd14f2da63577e302b9c7ec016abcbbfbd1653a22ed646f6980fb4e6d0994a9aa4a6c28f0955cb60d581f2d2e216ab731ae405b3c02d0f14e8fe82f SHA512 ac958cca518164406feff07f665d6edc6113d547393ff28d29a64b8b3f1bae306255ebf859f3e5f1fc75fabea985e1dd24d47c32766403b6ffabf9c31ff7ba45
EBUILD docstring-to-markdown-0.11.ebuild 707 BLAKE2B dddfd7969249382a629fde7aee7b081b2525b171eb1609a761974c79cabbdbf023e41ef83353acd44410d257d4a20c84f412847ee9ce9a9e85559248046a5b08 SHA512 a8a1f845b38af3d177d90db7cb4fec18d0853406bc10bd941835e441d57856ad5b65e42a71b1d4852f2d3b47ae277e2723b683d34074a864733c23507a052d1e
+EBUILD docstring-to-markdown-0.12.ebuild 752 BLAKE2B b6dc5ffdb861d7262a444a0a01d055d549204bcfefbb965056afd94f622561d44e12ab26ca7a6822ee89eeac2f067ace17635dac2e62e6aabf689244d54564f6 SHA512 87ddbae97345a7846f28f8f56d601b6db5818a230ac2f6c6bfbcf62a07aea6b1555eddc60e2ec36d11f7b6aa9d17cb54952a05907f7d849590065bc8510f443d
MISC metadata.xml 421 BLAKE2B a6bf8b83336e2e1b67af703c3ddc6d68a5ce94a3477902a9f6d7d35f8a5635cad265365820548959ccf861a14c1c24d5bb2fd934a6fc297ca20182b5686c3ec5 SHA512 952b36476833618a51a6c05181213fb8598237157e887fb81369084db327fc360e827ff2393e00f99141efa2256ea0701ca17005ddd337661a6d9e8f81fd3494
diff --git a/dev-python/docstring-to-markdown/docstring-to-markdown-0.12.ebuild b/dev-python/docstring-to-markdown/docstring-to-markdown-0.12.ebuild
new file mode 100644
index 000000000000..4b6be9b155a7
--- /dev/null
+++ b/dev-python/docstring-to-markdown/docstring-to-markdown-0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="On the fly conversion of Python docstrings to markdown"
+HOMEPAGE="
+ https://github.com/python-lsp/docstring-to-markdown/
+ https://pypi.org/project/docstring-to-markdown/
+"
+SRC_URI="
+ https://github.com/python-lsp/docstring-to-markdown/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not depend on pytest-cov/pytest-flake8
+ sed -e '/--cov/d' -e '/--flake8/d' -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}