summaryrefslogtreecommitdiff
path: root/dev-python/docker-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/docker-py
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/docker-py')
-rw-r--r--dev-python/docker-py/Manifest7
-rw-r--r--dev-python/docker-py/docker-py-2.4.2.ebuild56
-rw-r--r--dev-python/docker-py/docker-py-2.7.0.ebuild55
-rw-r--r--dev-python/docker-py/docker-py-3.4.1.ebuild50
-rw-r--r--dev-python/docker-py/metadata.xml12
5 files changed, 180 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
new file mode 100644
index 000000000000..315659989f7c
--- /dev/null
+++ b/dev-python/docker-py/Manifest
@@ -0,0 +1,7 @@
+DIST docker-py-2.4.2.tar.gz 180890 BLAKE2B 57518a0c8481fde0198100354225cd8a2908af6d3ca2690d98ad80b386ca4c688c7ccd6a34634ce04fb5ab1553b6c0dfbc75d28333a10f28de7188fe2ee7ffde SHA512 3367066b2acd96b85bef28aef00c91d752dc25b3055575b4f2f9c0b981eb4bca81a742bc6da5f97cf039cd9c7d818e3f80101997fe3a2e2c6f3a9c42fd3111c2
+DIST docker-py-2.7.0.tar.gz 196369 BLAKE2B dd181dbf32f5afda06e748cb49f15d5fc6ff4a579c64b505308ad0d96913ddc8065d165090ec2b20e1f17a4519988a5665dd7a8c7643ca53aaa4385ceecb1341 SHA512 15cf1d8949d71e472f7636ff975cbc4c5f3e18e2d193cb603ade1397a56d0c1ec239167b71be325af99105bc36590a0f0faa1ab010f36fe8baca7807ddfa191b
+DIST docker-py-3.4.1.tar.gz 207885 BLAKE2B 472f5dde4761b02a2b55c64762a0529dbaecc8aa9f0e24c67770f533341a5ca9c7322bfacba81f99f9305f09d4e5f7d7ccf37201f5e987777c33c6f81552a807 SHA512 447dccb9129d549886882e6cf0a8ac56d91f7ed57b6aa1dca1942c62d70dc78b92184cbdd9ac5f3445be04cfaadf0b4fba191fb70e223e93c6d1cfbfd334a397
+EBUILD docker-py-2.4.2.ebuild 1578 BLAKE2B f09a649f8ef49dbecddfdc8fa74dcb2e03bbb1aa72ec90488ec0da4f5c320c2872dda32838ba237e9c5df52cd8384a51b8f20286929b9a76511a09fdd9de3615 SHA512 98bdc785eac2b65557f3079c51d46d44ac47e1d3007bca99b4fd26d7d03b8e7826fa49646039cf659c75b7c660922af290def904bedc554b485471e78eded83e
+EBUILD docker-py-2.7.0.ebuild 1531 BLAKE2B d2d1ae4449c2379b07a0e3dd6eaee69f303d035a9d1b234359eff53bcd4ad2a40f271aff3e7e13e7e66ad49b8f7d6bd788076ece3896a8b06f5580af1f82554f SHA512 807b2a01920c4efc9ca29699ed05cc4018bc76faa343d729f627886412248e702c48e630a0fcca134f0c3c1a7b7eeb61ef8b132f920bc8260702c2ac40b7aca6
+EBUILD docker-py-3.4.1.ebuild 1401 BLAKE2B 403e424e83ee8234197ba80e26e0efea57c22bbfa8df00e1af89cbee96fa4fb131edd3a45c89192a47c141a52e317a79923c303f8d320362194636f86317fa6e SHA512 cf34bfd3985f0eb4e4c139a2327a306ecc5a2a581206c0f51a62f0c853259b7bb5caba6850c2effd40d9b3ed52682c2f65b6079c86558b9ed4ce1da7ad0f0963
+MISC metadata.xml 402 BLAKE2B 449733b9057dfcde3dd0ff82df6a9cf870d1138d3c721a39174a71f54a359422cb3411f513f68662b1c840480c4aa253f8fe77a2afe1020e82c4e7c81dc4d691 SHA512 13bee9843188ebf018e25e2a738fd0ecc10ddb3508bbbe3e47048a9ec714196498ea71044a57a20b4c649eacd0672b956d20a3e5487047723cbda9047ca214cd
diff --git a/dev-python/docker-py/docker-py-2.4.2.ebuild b/dev-python/docker-py/docker-py-2.4.2.ebuild
new file mode 100644
index 000000000000..da2a393fa746
--- /dev/null
+++ b/dev-python/docker-py/docker-py-2.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.2.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i -e "s/import pip//" -e "s/if 'docker-py'.*/if False:/" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/docker-py/docker-py-2.7.0.ebuild b/dev-python/docker-py/docker-py-2.7.0.ebuild
new file mode 100644
index 000000000000..df541cde5208
--- /dev/null
+++ b/dev-python/docker-py/docker-py-2.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.2.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i -e "s/import pip//" -e "s/if 'docker-py'.*/if False:/" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/docker-py/docker-py-3.4.1.ebuild b/dev-python/docker-py/docker-py-3.4.1.ebuild
new file mode 100644
index 000000000000..d3e8810d7e69
--- /dev/null
+++ b/dev-python/docker-py/docker-py-3.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.3.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/docker-py/metadata.xml b/dev-python/docker-py/metadata.xml
new file mode 100644
index 000000000000..c95aef16078e
--- /dev/null
+++ b/dev-python/docker-py/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">docker/docker-py</remote-id>
+ <bugs-to>https://github.com/docker/docker-py/issues</bugs-to>
+ </upstream>
+</pkgmetadata>