summaryrefslogtreecommitdiff
path: root/dev-python/doc8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/doc8
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/doc8')
-rw-r--r--dev-python/doc8/Manifest4
-rw-r--r--dev-python/doc8/doc8-0.11.0.ebuild44
-rw-r--r--dev-python/doc8/doc8-0.11.1.ebuild38
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/doc8/Manifest b/dev-python/doc8/Manifest
index c4c2eed79ed6..97ff62982a34 100644
--- a/dev-python/doc8/Manifest
+++ b/dev-python/doc8/Manifest
@@ -1,3 +1,7 @@
+DIST doc8-0.11.0.tar.gz 25540 BLAKE2B 4ccfd741da44206e12ec0adcc2155534225363fdd034dfef259b425fc862bfcb62eea691bc86bb39d0fc26fda036956be4f60eaa2214a8eaf6ec1086fa83ec1d SHA512 9a8b57bfe21dcc7302fbdcb9b5f1592c7449b43d4475622926b794a0e9041e85ae7806990517e911348f78f5871133983ec0feab13cea3ccca7e75449e519351
+DIST doc8-0.11.1.tar.gz 25643 BLAKE2B 5f7eaa00b6fac123d02da41e02c7585c7c7160664766466a3bf06ba146411fda14b3720f8c8277f307f7b4985ded47707c836f9f6e6d7e4f89dc1af50111b87f SHA512 88b0882af3a671afc2a87d9dea0df5e7890895907545ff8fc02b40ae7f765c142bc715bff3e90685dd1d2358b701b8c6c30cac431fe3d6d0ec078b78added2f3
DIST doc8-0.9.1.tar.gz 31122 BLAKE2B 84708d05414fe1545558910d0d74ae9612091500efb1880062910b395f1244c6edb1fe1c95ff97a177fcbb4127fcbc4b819a749f90c8384c0c23e9041af12b25 SHA512 058403a808ec2d55cf732c8eb0e28f6902c935a6fe0fd4e3ce1a11088888f32875a416adf478b81192948ebd581548b2d1591581222f1e841e97777980a80d69
+EBUILD doc8-0.11.0.ebuild 980 BLAKE2B 28a18e1be23517c2800529698bc5d20b1f403787db8541a487ea1f2f1ba03107a21da1162027978fa2ffdce1ed1a75ceeafd3adcb68298d8217c6dd9b6425394 SHA512 d6918771c18d877c00e6da46de4cab1594e1bcf8581498aca5da54f239b78dd7be2dd8a193cdc6657f0881ffbb24b10c4898426eb0ec95c7a2a00f64a92a49e9
+EBUILD doc8-0.11.1.ebuild 874 BLAKE2B 4e26e3c0c0e793667ec5df1568cd29c4d59320e3e800a97f5b9181a1c813c090c78bbe5b9e6fd65b1b813290a446f857b046e218d49b3d9174920b154f1c2557 SHA512 ed38964ab276076c8af3ee04a87907e07c328bfe1265135109d7689d516af606e040d68ae3bb33d36d20a0cab3affa7f3da6830b181b5cd42fd55df6c04f57b6
EBUILD doc8-0.9.1.ebuild 956 BLAKE2B dd8560d5039ab6eb66eae7119817335c7971bb47ed6e9f87b13421deb3d1b52fa7912b6e175a296966b016bca9db6f1123d4b40e325532dcb2f00b46226dc2cd SHA512 fe8e223be01c1c9409b100c13ce7d80e2583a678d91c0f94f7648b6faa944aba4a64c532ea11f3337fee64bb13fd73f9f8f67cc78fc16d2e3a2f09955e3f6904
MISC metadata.xml 322 BLAKE2B 0dc9c91cdb78ef3c143f7e45ac3ee3754643c676c249a685fdc73ee8f7468e19eecd6463fcb873b4a242789aa6c8f65ef92c45a1a5dc61c21bb070ae055f6553 SHA512 a417cd533ae3ef3b64cd170caa7e84fdf761be3b9b35178357134bcd5ca487fd5d4286cdff4718b345afef06cd63d5e9511431483ff7ba3ce5b5aca4ebe8ef41
diff --git a/dev-python/doc8/doc8-0.11.0.ebuild b/dev-python/doc8/doc8-0.11.0.ebuild
new file mode 100644
index 000000000000..4f9d8a2a0054
--- /dev/null
+++ b/dev-python/doc8/doc8-0.11.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="
+ https://pypi.org/project/doc8/
+ https://github.com/pycqa/doc8/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? (
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s src
+}
+
+pkg_postinst() {
+ optfeature "checking pyproject.toml projects" dev-python/toml
+}
diff --git a/dev-python/doc8/doc8-0.11.1.ebuild b/dev-python/doc8/doc8-0.11.1.ebuild
new file mode 100644
index 000000000000..b6e36fe26377
--- /dev/null
+++ b/dev-python/doc8/doc8-0.11.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="
+ https://pypi.org/project/doc8/
+ https://github.com/pycqa/doc8/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s src
+}