summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/dnspython
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest2
-rw-r--r--dev-python/dnspython/dnspython-1.16.0-r1.ebuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 47f522553865..0bebf646c353 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,3 +1,3 @@
DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
-EBUILD dnspython-1.16.0-r1.ebuild 1097 BLAKE2B 552b62a308f5f2b4fc13289ce986a8162c42711ad88e3ca958cba2d31d73a15d13a5a95cda07a483e53663df126362b3677f7f822a1f4417d0a0a916ffbadd96 SHA512 3aeaac7e1b47bfd6a1c4184bcc8c760829e336f996174b383a1a4fe5d6607f180eda1a9cc243965271e12ff123485899467605d15a55ec571d4a1247a2d71586
+EBUILD dnspython-1.16.0-r1.ebuild 1220 BLAKE2B 46755a8947a5a498027479a747da4a044256c3a80aae4bb185b44f1c799b52756b4b0de24f98d4b48ad692914386ac90b3dfeea02486f04a2dfe3ae1ca159b12 SHA512 1e7c19fd6f5a2d0a4be0395bbb46c83f570d70e0ad932bd84e5b301f926ee22fab45f12494ae7f6f223b2b314b3515f4c98e07853596d863ce2bdae45e9ea943
MISC metadata.xml 1482 BLAKE2B ff7895525a5fc62d104bf3039aa4154d0dbd5b097b5ae213c7e34713c968077b914b7a93ea881f43ea604e97b90f68b8f871a301f136de26ef4d98f0167be02c SHA512 63892286866fa85cc0a750157b3a2b98fdf4d3ef6edf61a879548c8e851cbeaa88cbfda52eaf98f1baf80e72a4ea2ffd2ceafe9794bf9a35ef3367ae5d3c2ded
diff --git a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild b/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
index 8de675f2314c..f6749205a505 100644
--- a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
+++ b/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -23,6 +23,12 @@ RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
!dev-python/dnspython:py2
!dev-python/dnspython:py3"
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/test_resolver.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
pushd tests >/dev/null || die
"${EPYTHON}" utest.py || die "tests failed under ${EPYTHON}"