summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-python/dnspython
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest2
-rw-r--r--dev-python/dnspython/dnspython-1.16.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index ea75bd94d302..7428b39e87e3 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,5 +1,7 @@
DIST dnspython-1.15.0.zip 252157 BLAKE2B 6766c1e69bc4225b08f3b1b3871fac2aba7ae707de5f16718798ce4d6846308500c5341f9ace1b48d3858ffc965a7295ee42cc2c35ff23ac38d71927dcaecfe9 SHA512 942f7cf083d1b0a9f03f040ceca194c38777f2e40862c388051986112b3f2a4a8426733ff46ec5a155319776e4a856412c3430b052b2f92f251f0e3260eb9bc1
+DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
DIST dnspython-1.16.0_pre20180731.tar.gz 182538 BLAKE2B 3a472091fccc4f37d65681727643677472837fd6be0c4fd6aaa13afd1fd4362eb27a5ba4ff6babca46fe15c2f5318ddbba22ce058b522f763baa797e1e2d1ab9 SHA512 67d17ab7cb48c370c3c2dd5cb935eec5ab7e3ac0c912e179931f395899ad186ba869edd8b870c043ba9fb3545bace18549d2a377f2ae2c278660fc488e68a20d
EBUILD dnspython-1.15.0-r1.ebuild 1030 BLAKE2B e295a0d3dd2d9a3a9119b973d0dfeba069474ec810c14dd8769f2736524386de3980c4eaed66702b4ac5ccb5f550f1a6c8e01391f6a27e1106ef64a9b8b3d0f8 SHA512 b9096e129cc0fd5c2fb93a1b9b4ed4415cbf091a9033de170cacf9bb770e7912d7449def6561a570473f9ceeea2f83563373e43a6339a29b475295f4724f6233
+EBUILD dnspython-1.16.0.ebuild 1162 BLAKE2B 5c861148155ba2b2aae7acb098fdf58868ceb19357e5e717624ae21ca3a2d329b65e50e324e3fd096c25e2fe46155b467461d548439e28d0d835cb273cfddbf4 SHA512 3fd3ce2a9a9ca7c97c3704bdc6f49eee63c9ef084b802326a31b750c1d042dfc5a7303fb4e17ab3fb67b371eef2102420be513898a0b8c69cf3d0a8b3dcba980
EBUILD dnspython-1.16.0_pre20180731.ebuild 1224 BLAKE2B bd50703c79abc827e745ba915aa103b02bda0550cc7901780be1f428145e6f3df0932b1c5a2c645f5a827525ef95c8000280c7a879d847c547566b43435e1006 SHA512 0ea74618e8e37584056f1e83def3e7ce86920b67bbfdd1b7387acb7f629fdb27c0cfd0b39694dea41aa02b5690da2039e766bcdaa3b7cbfbd70cc270b2778dbe
MISC metadata.xml 1458 BLAKE2B 9a04546a3cb62f7ed6a72a8416e7f38aca15733a444970e84fe0134d0097eca4ae8fab9433f66196539de66a4b6b92103a4531f9248cf508a2e0f4d16c85c172 SHA512 40c86234936ba4f0c01a98266e74d49a80a8a48d4761b887ec84fe3ff9b534e7b6daf3c317d299b1333132a6025e49abf63884e7d6d0634c876dc74b470e0a7d
diff --git a/dev-python/dnspython/dnspython-1.16.0.ebuild b/dev-python/dnspython/dnspython-1.16.0.ebuild
new file mode 100644
index 000000000000..99bce355fb93
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.16.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/ecdsa-0.13[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ !dev-python/dnspython:py2
+ !dev-python/dnspython:py3"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}