summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 05:39:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 05:39:40 +0000
commitb24782302154e447b59c3f719970f951cd15cd38 (patch)
tree463a954988b9099fbc02967de0cf25b250d0caf7 /dev-python/dnspython
parent753ad9170f0d68e7f525f1931bc6ebf359268b29 (diff)
gentoo auto-resync : 19:02:2024 - 05:39:40
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest2
-rw-r--r--dev-python/dnspython/dnspython-2.6.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index e0549f0dcbf1..ca975c037533 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,6 +1,8 @@
AUX dnspython-2.5.0-musl-test.patch 2797 BLAKE2B 0f2b3e9cce32de491ea9fc1c896a0acbf27972a75fc75fca9440faad1aa4f2e5adfaf44f2f94518fcc95793381d73c742d902fd94d44262be6892b97d7414011 SHA512 93ca5a2cce940c505a35846aa96cdae235f3871c4b2e871ed6b61860c4b22cf927b684ca9c651bcf1c1fd939990fe1145adb9217d42715c6dba10608a9a5e90d
DIST dnspython-2.5.0.gh.tar.gz 366093 BLAKE2B f8e3d8632a74b0421f7c77316dc80e01936277d701c282239ed60e79952755d34c673f15e19d4da812883e33d5f2cb54a8faa419185d8d198de923a2f3861095 SHA512 8ed207f9cee88dc1deb626d727c510dabace327586911e340df435c8cce5936efee51937b52881b4b4452d9c8c5bd903044bfef5a4effa95aaf05f24c0213b07
DIST dnspython-2.6.0.gh.tar.gz 372953 BLAKE2B c35a994ff0573a175a8011ef84291ea9de3450e4e57ae059c756cdb5e3163a736057b994e0d370b3c237eff7cf2650b7faae1f11071c53e9c953e655f539f8f3 SHA512 68361d624af6b308669a20316c9046e23135fdaec69f0dd0580f865b363565b813d836aaf9ddd1db5c51a831bd34ddbf6136b6bf72d2e91833d4c7c209528c2b
+DIST dnspython-2.6.1.gh.tar.gz 373684 BLAKE2B 63ac506d528a9e3684daf4888b51d732d9a12c3439ff1c353250a7bad78781f9f12bb13509e69093d5585a4a04bf2fbb1b8eb690a39f27e5d58e8f0f3b3b36a8 SHA512 77e9c69ac70e9e31a11188b968d28b8f2890b053b2cce0e608eefad7fd2c2b0f30c074222b2e5e85c0b4b8705f2e45acfa8b016a7808cc421df1d77f2561d978
EBUILD dnspython-2.5.0.ebuild 1210 BLAKE2B 95debb590399bf85840b458cd562dc378571150cb691f2ca3deee71afb74ac091681670a16af4d58dc6076f62768197d16b5ad72aa4118bc008b53d540d92c3a SHA512 b1b5f5d16de165ea0ed08d9fe9cee3e4756c661cf706e837368102396c71f6a765b3a2bd006da16018935bd77d067b765e3e6d1b2103859829407cf6373bbbc6
EBUILD dnspython-2.6.0.ebuild 1027 BLAKE2B 0575a64e02ae1f60d17083e87b30b3a7a90735c2fcd0014c16a52662dd5dd5017ce683ba03c8d936bc9ea02c7529ca584612201fff2301a295c362c6d63a06e2 SHA512 3c8798e6fe0fa22fab1de512b4b2c5e4b46493598f0a0bc5bdd87a8a7a8ebd01bc8624728ed2a8b450aa844f626c439aaa85aff92e52ba2c41db2bafa5f5c13f
+EBUILD dnspython-2.6.1.ebuild 1027 BLAKE2B 0575a64e02ae1f60d17083e87b30b3a7a90735c2fcd0014c16a52662dd5dd5017ce683ba03c8d936bc9ea02c7529ca584612201fff2301a295c362c6d63a06e2 SHA512 3c8798e6fe0fa22fab1de512b4b2c5e4b46493598f0a0bc5bdd87a8a7a8ebd01bc8624728ed2a8b450aa844f626c439aaa85aff92e52ba2c41db2bafa5f5c13f
MISC metadata.xml 1709 BLAKE2B abd502753325fedca3f1ca94818258c9d1b82f88766f9e005b35b3e79aff71ca2efaf06188e73ea30830f80ec011cdf5c42df320130c9295e13d3c427a148f8c SHA512 8c25d579a4a2a7c5ff34c21643a1386a434545f6b9b465f4aa8e07f7da3aee203bbc0341e930ddb767af431f64e8024ddd6cc8513cfce862c5900da4637bb1c8
diff --git a/dev-python/dnspython/dnspython-2.6.1.ebuild b/dev-python/dnspython/dnspython-2.6.1.ebuild
new file mode 100644
index 000000000000..fa76df91c401
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="dnssec examples"
+
+RDEPEND="
+ dnssec? (
+ >=dev-python/cryptography-41[${PYTHON_USEDEP}]
+ )
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-41[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}