summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-python/dnspython
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest2
-rw-r--r--dev-python/dnspython/dnspython-2.1.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 4f94bed061c7..d18d0c2361d9 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,5 +1,7 @@
DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
DIST dnspython-2.0.0.tar.gz 221903 BLAKE2B 540fb5fb12791dad6bae4007a77201092c8d5e64b7d82b23d5e3d16f48b49f73c90b85a6c8a83fa056a35cf7975ea2ad4a030f2b1fb1b87948bf1703adabb9d6 SHA512 3b38850fcacb0dd25ac0345201474f297c402617e8d706f3061c42172d697103075098e62ca0ac4e0e29967e00407f32f41789ac7bf070fba5aec0af9882e0fb
+DIST dnspython-2.1.0.tar.gz 279625 BLAKE2B ac90f1c9b50a00924326437e08513df04f3cf6dddee8b5ce58e628beab625d00c2dcdcc89e4b4da2c0366e650a5d8e87eb010942303215d3095e35f2010d4928 SHA512 eb3ab812eb8769b4780055b801e4f89beb1cb3d3e5a4855e583dca83b794eb7fca8fc3ef401eea7c16c34452e801dec5a2c59304f4041a68c7214dea6076435a
EBUILD dnspython-1.16.0-r1.ebuild 1210 BLAKE2B c5f5e93d3fbfc9de2ea54283afaa5a5bcc310f8c1b58a63b79b5fb884f2a3cff4b5cca084a14369afb6978c29b61a70b6ca726a3f825fb5127da8a34d8e05818 SHA512 82f6f0191dc9e92557d022ddd274e5aae276ceea1c247a7eb63d186f4d49d44980fbf8490626eb9c6818e7785d6f47e280ca442e396670552e9ef5f0dd163ca2
EBUILD dnspython-2.0.0.ebuild 988 BLAKE2B a70026656a37fa2875cd212390fedee095a9941cbbc7f8dc735eebed94c23c5796e9314fa0ddff721e5d9cb46a75797d7877e13223ea477b7f60506c7a3e0365 SHA512 60a5d290b67c10ba3751190033be0f04a84018cc506b1eea392cb11e4ac26040fe1438aa9d108c93bf745a881f27b460cdc9a9400f8def81fd0148dca3c69809
+EBUILD dnspython-2.1.0.ebuild 938 BLAKE2B 78a0faa4c9f63a92685e407c445069cd77fcb081b0389126980d213f29d4c96d53ba7c577be3c5d6775d3fcefa7785c538627b0b84a8c07fec73dcf3c84b5af6 SHA512 63ab49b902c3705e2b40176003787c140aa2150c2aab16c396e49bcc8e53f0e08420cfc107aa08b45f030113999010638151aad9acc9c997cb10861f4caa5c61
MISC metadata.xml 1482 BLAKE2B ff7895525a5fc62d104bf3039aa4154d0dbd5b097b5ae213c7e34713c968077b914b7a93ea881f43ea604e97b90f68b8f871a301f136de26ef4d98f0167be02c SHA512 63892286866fa85cc0a750157b3a2b98fdf4d3ef6edf61a879548c8e851cbeaa88cbfda52eaf98f1baf80e72a4ea2ffd2ceafe9794bf9a35ef3367ae5d3c2ded
diff --git a/dev-python/dnspython/dnspython-2.1.0.ebuild b/dev-python/dnspython/dnspython-2.1.0.ebuild
new file mode 100644
index 000000000000..8cee010f2df4
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="https://www.dnspython.org/
+ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}