summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-11 17:34:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-11 17:34:53 +0000
commit20ba650e8d3869757f6c89b23f8b41500cd64657 (patch)
tree81a698b712c41d64edae44805f36255228d681dc /dev-python/dnspython
parent70fb964b97d74b88cbbdd3fcbf5871d57323dfd3 (diff)
gentoo auto-resync : 11:02:2024 - 17:34:53
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest2
-rw-r--r--dev-python/dnspython/dnspython-2.4.2.ebuild51
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 293f90250816..e4c3f7f712bb 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,6 +1,4 @@
AUX dnspython-2.5.0-musl-test.patch 2797 BLAKE2B 0f2b3e9cce32de491ea9fc1c896a0acbf27972a75fc75fca9440faad1aa4f2e5adfaf44f2f94518fcc95793381d73c742d902fd94d44262be6892b97d7414011 SHA512 93ca5a2cce940c505a35846aa96cdae235f3871c4b2e871ed6b61860c4b22cf927b684ca9c651bcf1c1fd939990fe1145adb9217d42715c6dba10608a9a5e90d
-DIST dnspython-2.4.2.gh.tar.gz 357675 BLAKE2B ceb2f4a824a1c2b834401d2eb7943e62a5fb28a19be64cea8071d7e294d1a6aa80dc82266586d050fcb1c0eff881d9e139be335313d2098b6c3c6cf690f398ab SHA512 6a76331fc8bc282bb8ef61509317b1956bec6fb516a57409b1df38c8f5094e5ddfcaabc951f7678f1be75e735962c94f225b6e78eb4abe56b27e075180c62576
DIST dnspython-2.5.0.gh.tar.gz 366093 BLAKE2B f8e3d8632a74b0421f7c77316dc80e01936277d701c282239ed60e79952755d34c673f15e19d4da812883e33d5f2cb54a8faa419185d8d198de923a2f3861095 SHA512 8ed207f9cee88dc1deb626d727c510dabace327586911e340df435c8cce5936efee51937b52881b4b4452d9c8c5bd903044bfef5a4effa95aaf05f24c0213b07
-EBUILD dnspython-2.4.2.ebuild 1036 BLAKE2B 09065dc34e1d6c65eaa2efaeb7432a74ee004070a5e49ced70e2ad0aee9a7e38ef14decc18286410fa3aa2640c503d815e3c3fd870a2148a6376c0676130b6bd SHA512 dba146f266a31de5bace5606a4df9d7adce10cebf951fcb2e14d764216efaaed094f0a0b2ac2d2bd9dfbe7f837756789175629c5b251fe9ac72c2ec73f83388b
EBUILD dnspython-2.5.0.ebuild 1210 BLAKE2B 95debb590399bf85840b458cd562dc378571150cb691f2ca3deee71afb74ac091681670a16af4d58dc6076f62768197d16b5ad72aa4118bc008b53d540d92c3a SHA512 b1b5f5d16de165ea0ed08d9fe9cee3e4756c661cf706e837368102396c71f6a765b3a2bd006da16018935bd77d067b765e3e6d1b2103859829407cf6373bbbc6
MISC metadata.xml 1709 BLAKE2B abd502753325fedca3f1ca94818258c9d1b82f88766f9e005b35b3e79aff71ca2efaf06188e73ea30830f80ec011cdf5c42df320130c9295e13d3c427a148f8c SHA512 8c25d579a4a2a7c5ff34c21643a1386a434545f6b9b465f4aa8e07f7da3aee203bbc0341e930ddb767af431f64e8024ddd6cc8513cfce862c5900da4637bb1c8
diff --git a/dev-python/dnspython/dnspython-2.4.2.ebuild b/dev-python/dnspython/dnspython-2.4.2.ebuild
deleted file mode 100644
index 31bcaba25d68..000000000000
--- a/dev-python/dnspython/dnspython-2.4.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="DNS toolkit for Python"
-HOMEPAGE="
- https://www.dnspython.org/
- https://github.com/rthalley/dnspython/
- https://pypi.org/project/dnspython/
-"
-SRC_URI="
- https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="dnssec examples"
-
-RDEPEND="
- dnssec? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- )
- <dev-python/idna-4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest -s
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}