summaryrefslogtreecommitdiff
path: root/dev-python/dnspython/dnspython-1.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/dnspython/dnspython-1.16.0.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/dnspython/dnspython-1.16.0.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.16.0.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/dnspython/dnspython-1.16.0.ebuild b/dev-python/dnspython/dnspython-1.16.0.ebuild
index 99bce355fb93..6baa9b62a202 100644
--- a/dev-python/dnspython/dnspython-1.16.0.ebuild
+++ b/dev-python/dnspython/dnspython-1.16.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-inherit distutils-r1 vcs-snapshot
+inherit distutils-r1
DESCRIPTION="DNS toolkit for Python"
HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
@@ -13,8 +13,9 @@ SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="ISC"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="examples test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
>=dev-python/ecdsa-0.13[${PYTHON_USEDEP}]
@@ -23,12 +24,9 @@ RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
!dev-python/dnspython:py3"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# For testsuite
-DISTUTILS_IN_SOURCE_BUILD=1
-
python_test() {
cd tests || die
- "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ "${EPYTHON}" utest.py || die "tests failed under ${EPYTHON}"
einfo "Testsuite passed under ${EPYTHON}"
}