summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/dns-lexicon
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest4
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.8.2.ebuild58
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.8.3.ebuild58
3 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index 8bdadfd31e98..a577ea151fe2 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,3 +1,7 @@
DIST dns-lexicon-3.8.1.tar.gz 7832379 BLAKE2B 01049b6aaff661e24a39e70b5c04d5d4b18886ba88ccd61072736be5df99b9f880ed8a43b17f4fd9ad5c95ac1ec12d43a1b31ce69b115b7007cd1a95bacccfae SHA512 6826f1c3ceed43f207e4223a1f1ed231a7ada9c930fe61f76e353a20c979ec09dcc754dedc365d01870e74dfd36a3148582a5393dfe6733309e28e495fc495f9
+DIST dns-lexicon-3.8.2.tar.gz 7831952 BLAKE2B 4d24d1083fb5fe7cd3ee55b6ad0373fdcc8fa8faeae50a7434f8989c09ab6b16287aa97e37ebdd02fd406c94f364d2e351aaf04b413e18d64ecaa17228952059 SHA512 98ad0942a4f28e57803821a6cf840d6ea21a39478fd565dfc5c2cfb6be8d55d44f52d7247772fc9f7031139aa23dafd244b3c454435446ada186f115326469bc
+DIST dns-lexicon-3.8.3.tar.gz 7834913 BLAKE2B a72b356d10d0af8367ce9d51d2c4d4a3a1cc8aa26d5edfa2cb1aca4b2eb67acdcadc46f46d5457430708f94fda9654a87ded76fa796c44a4b4e2a0d4f3accd13 SHA512 3035e9c5d073feb0dd910b79d8de02f2e9bfc81f922bce34ad33c22b583896a781e50f85104799a13133121ab5e88a372667cf0014399df50c5a829747d98073
EBUILD dns-lexicon-3.8.1.ebuild 1614 BLAKE2B e4491c94ba6fcd657c124325374c1adf65ed6fd14ffff2362335c9c3821fc640c18454bbc7d817930e6aff2cdb0a43fcfef80685b95ce471b6dc3abb0135ba1e SHA512 ce2f6bb1dd6bdfc1636efc74d98e910364f804f2e7a13955138a0f07bd7aac50ada97ea66bd862cbb93fc1882a3b4bfcc9ed4fc03675588cb44253154413685d
+EBUILD dns-lexicon-3.8.2.ebuild 1614 BLAKE2B e4491c94ba6fcd657c124325374c1adf65ed6fd14ffff2362335c9c3821fc640c18454bbc7d817930e6aff2cdb0a43fcfef80685b95ce471b6dc3abb0135ba1e SHA512 ce2f6bb1dd6bdfc1636efc74d98e910364f804f2e7a13955138a0f07bd7aac50ada97ea66bd862cbb93fc1882a3b4bfcc9ed4fc03675588cb44253154413685d
+EBUILD dns-lexicon-3.8.3.ebuild 1614 BLAKE2B e4491c94ba6fcd657c124325374c1adf65ed6fd14ffff2362335c9c3821fc640c18454bbc7d817930e6aff2cdb0a43fcfef80685b95ce471b6dc3abb0135ba1e SHA512 ce2f6bb1dd6bdfc1636efc74d98e910364f804f2e7a13955138a0f07bd7aac50ada97ea66bd862cbb93fc1882a3b4bfcc9ed4fc03675588cb44253154413685d
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.8.2.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.8.2.ebuild
new file mode 100644
index 000000000000..bf5ab2f7ce8d
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.8.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.8.3.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.8.3.ebuild
new file mode 100644
index 000000000000..bf5ab2f7ce8d
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.8.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}