summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-23 14:56:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-23 14:56:14 +0100
commitb818f6a820dceae80d6e3faac5fdf7be0c6fcbe2 (patch)
treeecc35732c51ff9d610d4a9e0cc77e940ef5ac9da /dev-python/dns-lexicon
parent2bae4d8bcdc3862f8d7cf1963acc0a9036762d2d (diff)
gentoo auto-resync : 23:08:2024 - 14:56:14
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest2
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.18.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index 0066ff62b35c..e956d28b7741 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,3 +1,5 @@
DIST dns-lexicon-3.17.0.gh.tar.gz 6200497 BLAKE2B 8f423d4d44517b3186ec7f5cfc5d1e0560d4c98360f8a9d6caab429e0b0e5abe8ee42545b0d7c4cdaf1e2a6a9af41b095198144fda386a207f4f98c7693bb2ba SHA512 1bc182f5881d6acfac72b84331ba50da1219178d274c92e532ed11e73aa79696681d28a002cd1e23f48590953f48e50b62c2ef2db020a07ecf88547717508c0c
+DIST dns-lexicon-3.18.0.gh.tar.gz 6216871 BLAKE2B df41467a253cf56c2dd5c127c431973fc80bdca4c174fe84649227d897d7b4612219ca5dc2ad66ae7dc75f626ddfd32aaa950b5cea699bfbb7f05c9a5bda7f40 SHA512 da2804caeef6cd96eb53f7414833757905afa269f328271fccbdb06d988fb46695a0cb917b8dbdfb66579b01cc98d07de8eb7e1cb132c47d49fe05e2ebe18127
EBUILD dns-lexicon-3.17.0.ebuild 1924 BLAKE2B 41798b1959d4a3a17e5c5cd419a17b14be30bcae2891195960a590cb0551c1d887e8f578d0222269778f8447155d9261624da3f52415b3618bf02e72be505a28 SHA512 5f1af9baf10e1667a85ba149ceb49bac966f7a9d213e855e63932a26c4c06c9771a4934e70e5041a2194b898981ff2b5701b65c471bf58c73455f8d26b218553
+EBUILD dns-lexicon-3.18.0.ebuild 1820 BLAKE2B 7a902395cd6533d84bb73f4f440d0be8e184ae8c1145daf7585ab5b8e330679eab6bced829d90c81b8620bb567d4892ce53210de3a0a27d822a3bbfd6e98a8e0 SHA512 7007f9c18caa2c642c7a2a1770a45189c30743840016a2b3bcd9d325ce37e62e05b70eb478a7244fe719d36c9078e85d51afd73580b4b1b8ea07e15f64a99f20
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.18.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.18.0.ebuild
new file mode 100644
index 000000000000..aa26fc580959
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.18.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ >=dev-python/pyotp-2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/boto3-1.25[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ tests/test_client.py::test_client_init_when_missing_action_should_fail
+)
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ tests/providers/test_transip.py
+ # Requires the "oci" module
+ tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}