summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
commitb6323af2602e6a5cd4920d4af06b5c2f3949b9d0 (patch)
tree7d427f015930068f8d06e8f5aa622635ac3b61ca /dev-python/dns-lexicon
parent4b61f038fc5ecca26609a997fcc662c7cf9e0498 (diff)
gentoo auto-resync : 14:08:2023 - 12:12:48
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest2
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.14.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index cca89ff31486..7a70adcece87 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,5 +1,7 @@
DIST dns-lexicon-3.12.0.gh.tar.gz 6729773 BLAKE2B 1566b98db71027a8c49c7c90060a67b0efc8dc8afb8c977c0277d29c751f26cabc824a510194f09d02f19a40151bfdebe877ccd3e0bfcc8484f694ce128c0d95 SHA512 4ba799c6f7a01b8209f5274337258d0525efff366b297fff2fcff1d40c7ee58850fa8c3743bf9d29a1a082288e1f615cd94036a9cdc7be9f85e46f26fe3d7fbc
DIST dns-lexicon-3.13.0.gh.tar.gz 6739417 BLAKE2B 86f879fb5b27c6d9b21788ce4a9d7573b9aca0eccc022f4ac81cbb0e683f089797156134720bcbd82b509253470b01ee3ead3161517a0108d16991b668e1b4f3 SHA512 582efefb93d9f122cf3f900ddc7cf615295855645f6d9621f14c11067e441eb67349adf40e5159b75e8c5703d1cfd874364d392ce2994feb89949d371b4b55be
+DIST dns-lexicon-3.14.1.gh.tar.gz 6747567 BLAKE2B 55ddba2caf71b92ad0e5f34457d33c46be5969b13a12ac16a07e5c9ad8a25b921119edf89ce80928340e401308365eeb5b7c7c56f8e36482422f7e2e43412cde SHA512 13e4c5b046cad28e487b246b7c16a3ee71b2dbca4c40e513b234cee62e483e7702ce293c11ef96b245409229a7cd3a39c1771ebfc7b2430cd5b017d33e32a924
EBUILD dns-lexicon-3.12.0.ebuild 1974 BLAKE2B 6f0b2f9d18b2066ab05393fe7190a136a01c6c63b9e6eaab6ba96a1d085305d5cf3013267b9bc04101ffb8841715dc161b034e12d73c54aebaf42d7ca4166aa4 SHA512 ae016160fa92993ba8007635dbf18ee9c4de868ccfe39d889a3ed7b773456a3be4f43e8f9a9f6653bdda9f50880af2b65894a174565542df8931ab773991f9f0
EBUILD dns-lexicon-3.13.0.ebuild 1974 BLAKE2B 6f0b2f9d18b2066ab05393fe7190a136a01c6c63b9e6eaab6ba96a1d085305d5cf3013267b9bc04101ffb8841715dc161b034e12d73c54aebaf42d7ca4166aa4 SHA512 ae016160fa92993ba8007635dbf18ee9c4de868ccfe39d889a3ed7b773456a3be4f43e8f9a9f6653bdda9f50880af2b65894a174565542df8931ab773991f9f0
+EBUILD dns-lexicon-3.14.1.ebuild 1918 BLAKE2B fa4274c3add2a44a14612dabf3f8382f858496df1584d173ebbcdb4ea2a04b4a90b12f3e959af00bfa27c61ec4c4f26807de475679fe39287478243a4934f8b6 SHA512 4758c1a5494dc2c7033ac6e37422a4de5bb3a432d894156c503ede539ff3115f5b0bee5ae29c6d6d1f6908716e92d38f5c52ee4220e9bf16f14e8539da865b5d
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.14.1.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.14.1.ebuild
new file mode 100644
index 000000000000..0ad281cbc901
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.14.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/boto3-1.25[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ tests/providers/test_transip.py
+ # Requires the "oci" module
+ tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ tests/providers/test_auto.py
+ # All recordings seem to be broken
+ tests/providers/test_namecheap.py
+ # Broken by minor vcrpy / urllib3-2 incompatibility
+ # https://github.com/kevin1024/vcrpy/issues/714
+ tests/providers/test_route53.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}