summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
commit7c68db06bb531670c1261374c0133d652b476bd7 (patch)
tree5bbbde86ec021664b3c6dfaf90e1175f8378949c /dev-python/dns-lexicon
parent0987983e8588d2819bb2ceb029792d511cee0bda (diff)
gentoo auto-resync : 12:08:2022 - 14:22:05
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest2
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.11.4.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index e0cdcdf47278..3359095cfbf1 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,5 +1,7 @@
DIST dns-lexicon-3.11.2.tar.gz 8479426 BLAKE2B aced03c62f809bbb22d2456da8d7a66c4b3cdfd47903a67cafd8a97cbc7cdbbe22fe7e79ad3eada716a569241def4e42cf7d910ba9837dfe05a31ce3f8ed2bdb SHA512 bf77cee4e483b36c8cc8cb176291f0170a1d611551246e27ddd91d9712e8750c9ee57863697e975065f6924c03fdfd636c5c7df29a620d37441b12dd0a1c597d
DIST dns-lexicon-3.11.3.gh.tar.gz 8442678 BLAKE2B 3898e572b409f19c6c3064046adbbbbfefe0ef287caceb2495972c946bdab0b4bb484330e3ae98afdc8d65cc849c11ed199e6c1eeeeb1296f09063124c166b91 SHA512 770a3c052ecc26fb3a27ac49b8f14132b69ea6ca9dfc93caea1ac66c4e6a458e6484b8a8ab921eea97761216fa34d8ad0d95964cdcff30a5713de7189c1e987d
+DIST dns-lexicon-3.11.4.gh.tar.gz 8429864 BLAKE2B 552c87427fc04683e3e6b540fa3e62f88628f833b8229d52dde9f53d77c1cc32968aa9b0c3d04876145067950752c8fb68c1540cee82cf5687bc16d26d7ebd63 SHA512 d7c1f085ffcb4589430f744970bbc6793779fb19d4cc29b071937d768cb271330794fccf38b60a82ed6362dda4101ac6643704bb703df242c8f2a17273dc6fbe
EBUILD dns-lexicon-3.11.2.ebuild 1779 BLAKE2B 9ae8f9050f5d22d5da832cbb8d1bb8b4aaa89968f3d789f02712e703f3f8555e4b7ab4b64f041e8712dd202140d1b873ddf1775b8d03dbad640161089205887d SHA512 f922bc0862a22b8cfb14d22269d69287fed4fcb6c0c225181d4c3b058b1307110bb2dcafcb9917078c43d1a4046f78378a2bea18ed4125b33430b0ac3e0bfb33
EBUILD dns-lexicon-3.11.3.ebuild 1782 BLAKE2B 11f3ea6b3a037c6a8ed45b0094a474335b0ef860f5096ee6159534b154237e190cfab56e604c1814b56944ba1954c9d8ff0349d39817036158f8e1991a0d6b0e SHA512 2a201b3edcc30c3efe7c11aef127d66cc571ac70176c4206e186999a98644fb28caaffc68724c191dbde17556bf3771563286028480e1e716d88e80b3ce8ac6c
+EBUILD dns-lexicon-3.11.4.ebuild 1782 BLAKE2B 11f3ea6b3a037c6a8ed45b0094a474335b0ef860f5096ee6159534b154237e190cfab56e604c1814b56944ba1954c9d8ff0349d39817036158f8e1991a0d6b0e SHA512 2a201b3edcc30c3efe7c11aef127d66cc571ac70176c4206e186999a98644fb28caaffc68724c191dbde17556bf3771563286028480e1e716d88e80b3ce8ac6c
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.11.4.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.11.4.ebuild
new file mode 100644
index 000000000000..c6c99ff85a56
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.11.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+ # All recordings seem to be broken
+ lexicon/tests/providers/test_namecheap.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}