summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 20:20:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 20:20:47 +0100
commit3d952d0bfe7b386699eb32d1431deb0c538f044d (patch)
tree45d2492f5c659cbb01120d4192c9be34841362bd /dev-python/dns-lexicon
parent522b6bf7e1f6133c288b94a77fc5e3d8eef2c179 (diff)
gentoo auto-resync : 12:06:2023 - 20:20:47
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest4
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild3
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.12.0.ebuild70
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index a59764b42e45..d59b3b51a5f8 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,3 +1,5 @@
DIST dns-lexicon-3.11.7.gh.tar.gz 6677647 BLAKE2B 9330bcc81e053e9cf8b2171b444e5d20e86922da15df7121a5957f8e6932528ba1f9099cc4dff08b2825d8fa253369b8b2da026a0846e64896bf491c59f2bdc9 SHA512 7d3becea6b9d60a4589e9d7e8de010d0b7e6a2c127d1ccc6981d1bff88d09f5a708fd3e9e22f66b8a0a77a331784340662de73607dd25d69c0342795c6afc765
-EBUILD dns-lexicon-3.11.7.ebuild 1783 BLAKE2B 04bc277d951a7d41b88b854e908bbe4f6465bc040bd60365220f673ba6b39f2d04f08530a0d3b79e98fc2b0b30118a5553e41780d5a7a255bcafbfdf7015c5be SHA512 a05126ada90a7f595a0aa153c596c1ec740e072908b9b34333beebb1a554fb445a1a3c6b9a4247e8e6dbfe2fdcd9752761cc17e5425b311a2a5ed233c68b0d0c
+DIST dns-lexicon-3.12.0.gh.tar.gz 6729773 BLAKE2B 1566b98db71027a8c49c7c90060a67b0efc8dc8afb8c977c0277d29c751f26cabc824a510194f09d02f19a40151bfdebe877ccd3e0bfcc8484f694ce128c0d95 SHA512 4ba799c6f7a01b8209f5274337258d0525efff366b297fff2fcff1d40c7ee58850fa8c3743bf9d29a1a082288e1f615cd94036a9cdc7be9f85e46f26fe3d7fbc
+EBUILD dns-lexicon-3.11.7.ebuild 1926 BLAKE2B 88d2c939ef6fd0a540c02f81c7f57025ee1ed69c8a875af0ad5db4b0e6436dedcd196af1d52e3989a125395651cf5741f7f28ff03c8da65750130d5851378270 SHA512 123039e1b106e28f96c5f077a7c4f5820c76fe1f174188052f7c951246f51ebf1606afdd7bfa684ba3baf5b8798a4f1d81ddd79687992f47ce66dc51a7aaa1c0
+EBUILD dns-lexicon-3.12.0.ebuild 1933 BLAKE2B 4046b9ec92670648a9a7aa6ae86c4992c8b711fd305826ee7725658b4d2092509a72c2b66f18c1d1ee35ca8d73b88c5560d0ec925f58566ff9fe2ab038d7181a SHA512 b3ee015385e844654a2c79df4c3babf47c28eb9699ece0d47c982b7e98416b59fe5a133194e18aa58dbb6bf6e79738bae03ef13bd415bab0d120144b8c8609f7
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild
index 61b3bb1da894..021971429400 100644
--- a/dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild
+++ b/dev-python/dns-lexicon/dns-lexicon-3.11.7.ebuild
@@ -54,6 +54,9 @@ EPYTEST_IGNORE=(
lexicon/tests/providers/test_auto.py
# All recordings seem to be broken
lexicon/tests/providers/test_namecheap.py
+ # Broken by minor vcrpy / urllib3-2 incompatibility
+ # https://github.com/kevin1024/vcrpy/issues/714
+ lexicon/tests/providers/test_route53.py
)
pkg_postinst() {
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.12.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.12.0.ebuild
new file mode 100644
index 000000000000..4bbd2608a19f
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.12.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/boto3-1.25[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+ # All recordings seem to be broken
+ lexicon/tests/providers/test_namecheap.py
+ # Broken by minor vcrpy / urllib3-2 incompatibility
+ # https://github.com/kevin1024/vcrpy/issues/714
+ lexicon/tests/providers/test_route53.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}