summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/dns-lexicon
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest4
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.8.4.ebuild58
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.8.5.ebuild58
3 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index acdbb9ac43c0..8061816f4a38 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,3 +1,7 @@
DIST dns-lexicon-3.8.3.tar.gz 7834913 BLAKE2B a72b356d10d0af8367ce9d51d2c4d4a3a1cc8aa26d5edfa2cb1aca4b2eb67acdcadc46f46d5457430708f94fda9654a87ded76fa796c44a4b4e2a0d4f3accd13 SHA512 3035e9c5d073feb0dd910b79d8de02f2e9bfc81f922bce34ad33c22b583896a781e50f85104799a13133121ab5e88a372667cf0014399df50c5a829747d98073
+DIST dns-lexicon-3.8.4.tar.gz 7850337 BLAKE2B f72a338c00346091df2cf53fa01cbc34e81b235cb5100b4993ccf46f738e2588b08b7a57316c07c7eff1c039437e49371193c9952b6fd870f30a2c6b538d3e1e SHA512 7a598b38a847e384fda243b76af523701d80d84a2338ef5745ca9f82284675ace5f84bf93cccfeda101584194c15fdbd0d4d8f69fdd0db60ec42d4c063a7916c
+DIST dns-lexicon-3.8.5.tar.gz 7850115 BLAKE2B 27dfb837385e370142d82bc682627fa96efc8a4868f9a5532ace608e2739afbecee82dcb531e9a4e0cdf9b2c68e639ae5c7ad1f4774e80f989c13eaa86c93d7a SHA512 e50fdb5c0b0d250babaff0a2d485f9112732a9e975cb853329dbcec33fe592e80a28c469b17cc0a5544909285805c1c20578b5e5f4b22ff6259b624be8c6acde
EBUILD dns-lexicon-3.8.3.ebuild 1614 BLAKE2B e4491c94ba6fcd657c124325374c1adf65ed6fd14ffff2362335c9c3821fc640c18454bbc7d817930e6aff2cdb0a43fcfef80685b95ce471b6dc3abb0135ba1e SHA512 ce2f6bb1dd6bdfc1636efc74d98e910364f804f2e7a13955138a0f07bd7aac50ada97ea66bd862cbb93fc1882a3b4bfcc9ed4fc03675588cb44253154413685d
+EBUILD dns-lexicon-3.8.4.ebuild 1614 BLAKE2B e4491c94ba6fcd657c124325374c1adf65ed6fd14ffff2362335c9c3821fc640c18454bbc7d817930e6aff2cdb0a43fcfef80685b95ce471b6dc3abb0135ba1e SHA512 ce2f6bb1dd6bdfc1636efc74d98e910364f804f2e7a13955138a0f07bd7aac50ada97ea66bd862cbb93fc1882a3b4bfcc9ed4fc03675588cb44253154413685d
+EBUILD dns-lexicon-3.8.5.ebuild 1614 BLAKE2B e4491c94ba6fcd657c124325374c1adf65ed6fd14ffff2362335c9c3821fc640c18454bbc7d817930e6aff2cdb0a43fcfef80685b95ce471b6dc3abb0135ba1e SHA512 ce2f6bb1dd6bdfc1636efc74d98e910364f804f2e7a13955138a0f07bd7aac50ada97ea66bd862cbb93fc1882a3b4bfcc9ed4fc03675588cb44253154413685d
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.8.4.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.8.4.ebuild
new file mode 100644
index 000000000000..bf5ab2f7ce8d
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.8.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.8.5.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.8.5.ebuild
new file mode 100644
index 000000000000..bf5ab2f7ce8d
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.8.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}