summaryrefslogtreecommitdiff
path: root/dev-python/dkimpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dkimpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dkimpy')
-rw-r--r--dev-python/dkimpy/Manifest3
-rw-r--r--dev-python/dkimpy/dkimpy-0.6.2.ebuild20
-rw-r--r--dev-python/dkimpy/metadata.xml29
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/dkimpy/Manifest b/dev-python/dkimpy/Manifest
new file mode 100644
index 000000000000..ce1d805eb36c
--- /dev/null
+++ b/dev-python/dkimpy/Manifest
@@ -0,0 +1,3 @@
+DIST dkimpy-0.6.2.tar.gz 39197 BLAKE2B e52df97b03075461935e82d2acd17c6eaff8f9fb0b8217b1803dc54434ce2c002e1aa419b0293bdb130045be4edacceaf447dcfc566bef4a5e16e0651ac7365c SHA512 7592153270ea11f59dc67e31a10c91345389d4391f3a9dc9fbd1224410edab4743935763ad5b1016b321bfa7b1c4c0255f26323bd5556f359b0b743bda4e515b
+EBUILD dkimpy-0.6.2.ebuild 455 BLAKE2B 1409b88e859675a64322c6acfca9abc8709173e627c9fbf4045546fa65088b3e97df379a0d510c7a2c310f5e32e90a8f7184b4a08d01da2f83983a2a2700296b SHA512 5e3e6adf1a6744e6b01216603d47fb95797f06e091a28c5e65386a34ccef72edd29cd2cd69cdd6fd8014ff418b73f633cd2400a4df0a1ffb7025134cf76344a0
+MISC metadata.xml 1249 BLAKE2B 736b664d21c016a962c592ce53a86eb3b5de462f6d0ace935bd4b58bd241f961a8b36e652e34fd879d17142ada4772ee583cf776591413ab48f6129f1b18e956 SHA512 b26ef946ab562ed51c8437d66566bc25920428b8c87b27674d48b7e048bb28acae53e14d1b28d780bf8cd85f6cbe34021e80fdae1d76e29107e825cc0fc575a2
diff --git a/dev-python/dkimpy/dkimpy-0.6.2.ebuild b/dev-python/dkimpy/dkimpy-0.6.2.ebuild
new file mode 100644
index 000000000000..fa70db8aa23b
--- /dev/null
+++ b/dev-python/dkimpy/dkimpy-0.6.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="DKIM and ARC email signing and verification library"
+HOMEPAGE="https://launchpad.net/dkimpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/dkimpy/metadata.xml b/dev-python/dkimpy/metadata.xml
new file mode 100644
index 000000000000..0c13f3889997
--- /dev/null
+++ b/dev-python/dkimpy/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python module that implements DKIM (DomainKeys Identified Mail) email
+ signing and verification. It also provides helper scripts for command
+ line signing and verification. As of version 0.6.0, it also supports
+ the experimental Authenticated Received Chain (ARC) protocol.
+
+ Originally developed by Greg Hewgill http://hewgill.com/pydkim/ - The
+ code in this project has been modified and development work continued.
+ This is now a fork of pydkim and we've renamed it dkimpy to avoid
+ confusion. The original author of pydkim has confirmed he no longer
+ intends to maintain it and supports this as its continuation.
+
+ Current documentation is available online at
+ https://gathman.org/pydkim/
+
+ ARC is still in development. dkimpy 0.6.0 supports draft
+ https://tools.ietf.org/html/draft-ietf-dmarc-arc-protocol-01 with the
+ exception of requiring 1024 bit minimum key size (this matches the
+ planned changes in the next update).
+ </longdescription>
+</pkgmetadata>
+