summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 23:30:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 23:30:45 +0100
commitf892e24578e434bbea68c4f1c9a8eef429461268 (patch)
tree5fc6072a72fd5ca8397e89183bad49896e6bf372 /dev-python/djangorestframework
parent0e7ef53ddcc33809bcb2644d3649617113b78ea3 (diff)
gentoo auto-resync : 23:09:2022 - 23:30:45
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest4
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.14.0.ebuild41
-rw-r--r--dev-python/djangorestframework/metadata.xml2
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 47f32c55cb51..5673f75a7126 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,3 +1,5 @@
DIST django-rest-framework-3.13.1.gh.tar.gz 8868916 BLAKE2B 01a2e1c2459f99b1d3b38b62b305a57f3a3358d34a352ef2bbeb6b130c98f19fbbb83325d1013c28107f267a0a0227215646975de54542ab9ca6dfcf2bd88404 SHA512 a272cccf1f19b2cd09ef456a9588fb17ddc56ac3bd735cf7e130d85bb667ca87361d7de26c95b58a05d8cf693ab19c09d913b457f17ad63053ff9b516c13ec9b
+DIST django-rest-framework-3.14.0.gh.tar.gz 9056443 BLAKE2B 217be67f42207d72d862011a72aecef3e111c1e1dd4b4e090cae6b22dee3fb32e060f7877c498084cf1221eb960b4ca895ef55721f7cabaafe3e36ee152e17a8 SHA512 c1012c656b427e0318b2056e2f984ddc75a5b4e85f375c76fba165ad06e285848eee1bc6dc76c097daec57d780efb2551110199d62ce636a03951aec13ab4013
EBUILD djangorestframework-3.13.1-r1.ebuild 907 BLAKE2B 765e6ec4c1e0b4523c59f880789ea23fa58b8ca6ef521558b1509c08e1f46f8a358f8f4434cec1705698365199ac74ab99f8024c5be44d0279cf917da40e5e40 SHA512 eb16af85f3d1c814660f85d6b95f828406f9687768ebd866d3b4f20a0acc38af4ba88114c4568dbc1c6e7cd5151bc37e97daf7007ab35638d39c986db31e51ea
-MISC metadata.xml 323 BLAKE2B 12b83c18a646ca1be9acf46d5d356ea87104edaca0a199c971fb44a26f385bea834603c9f5a8a4115e8239c3591cd9c5cb001fe365e19287fc00b2ebb07489b6 SHA512 d18e5df8d405716c16ed5d021d41d621b6f1f33c5c4fcda542a44f6a14544531709d7e0a093d40ec10802d2e3bf5ea534ce706d444af2a43b8845068bb1438cd
+EBUILD djangorestframework-3.14.0.ebuild 907 BLAKE2B 65849e4c3d1abfa346bc582747a9ba8137f6d4671f26a29f9e99d2c0fb7ff14aaca2927b092f32f35c25952dc948ea93963a90db3428e4c05aec4c1988f5e919 SHA512 bafb491fcdeba61a1ad1f2c2e58ddf7ae0d4cd8c59b23789c225130c385bf9f2432dfdce059d6e573019aaaf69560ccc3c15d0a591653c827b0288909e537aea
+MISC metadata.xml 415 BLAKE2B bb9ad83d104afc4bd68af5918b0ee30646b152c16115338e9a80ca4b6cdff52a15a9f1a7877d0964c974710b7a23401e8560ae9d621a57053cb10cd998dc699e SHA512 983ee54c8b07fa5078ce4e7fc87f1baadf540d8b5a25bbb34c1419e5892ad6c0dc518b617e02958b3dcf67aa02d24d74483917c37926f930608b83913afab334
diff --git a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
new file mode 100644
index 000000000000..c94e5e731e64
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="https://www.django-rest-framework.org/"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/coreapi[${PYTHON_USEDEP}]
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+)
diff --git a/dev-python/djangorestframework/metadata.xml b/dev-python/djangorestframework/metadata.xml
index 13d73d7e2154..776038dc345f 100644
--- a/dev-python/djangorestframework/metadata.xml
+++ b/dev-python/djangorestframework/metadata.xml
@@ -5,7 +5,9 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">djangorestframework</remote-id>
+ <remote-id type="github">encode/django-rest-framework</remote-id>
</upstream>
</pkgmetadata>