summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
commitc9e9e39938097bf29063c271195ad0d7d7bd02a9 (patch)
treef2f4ab36d22272fec3a1d1313d8f700b1f0f6744 /dev-python/djangorestframework
parent0968caae52d6eae7513e2ce4e0900a2e009780ee (diff)
gentoo auto-resync : 17:09:2023 - 17:03:44
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest2
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.14.0.ebuild15
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index d810829773f1..0e83765c2a49 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,3 +1,3 @@
DIST django-rest-framework-3.14.0.gh.tar.gz 9056443 BLAKE2B 217be67f42207d72d862011a72aecef3e111c1e1dd4b4e090cae6b22dee3fb32e060f7877c498084cf1221eb960b4ca895ef55721f7cabaafe3e36ee152e17a8 SHA512 c1012c656b427e0318b2056e2f984ddc75a5b4e85f375c76fba165ad06e285848eee1bc6dc76c097daec57d780efb2551110199d62ce636a03951aec13ab4013
-EBUILD djangorestframework-3.14.0.ebuild 907 BLAKE2B 4df49abee968b386c65b1b577bdd041169ac53773f1390219f24f67924634f0c3eea562abb00f164f1ba379c9896913b94d74ef992084fe2a7ad4e9bdbdcbd02 SHA512 12c05caef3ea5bbb4053390cdca4339861d0742d6765bb0f30a723572a44e4ca074506729a4dba4689b4355e4f972fef8516142e66e5c643eb53beb081577a90
+EBUILD djangorestframework-3.14.0.ebuild 1300 BLAKE2B 42ea96b672deb1d284f927963441c3b809b3a3cbdb045263b5da599580d2a55dbb013a519f22b854c7a21ce787295c22e282ad9236c7b501d7a51ad956ffb3b4 SHA512 2c9471fbecb6f62b97dec9436de485c1ae6db2f3fe319eb534005280a15f369b023a08ab45da8bbdf455b6e1789f0e959e60065095a1395a7ad9aac36685a3e7
MISC metadata.xml 415 BLAKE2B bb9ad83d104afc4bd68af5918b0ee30646b152c16115338e9a80ca4b6cdff52a15a9f1a7877d0964c974710b7a23401e8560ae9d621a57053cb10cd998dc699e SHA512 983ee54c8b07fa5078ce4e7fc87f1baadf540d8b5a25bbb34c1419e5892ad6c0dc518b617e02958b3dcf67aa02d24d74483917c37926f930608b83913afab334
diff --git a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
index b31831ebf043..516803ad767c 100644
--- a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
+++ b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
@@ -4,13 +4,17 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
MY_P=django-rest-framework-${PV}
DESCRIPTION="Web APIs with django made easy"
-HOMEPAGE="https://www.django-rest-framework.org/"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
SRC_URI="
https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
@@ -27,8 +31,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/coreapi[${PYTHON_USEDEP}]
- dev-python/coreschema[${PYTHON_USEDEP}]
dev-python/pytest-django[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
)
@@ -38,4 +40,9 @@ distutils_enable_tests pytest
EPYTEST_DESELECT=(
tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
)