summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
commit69051588e2f955485fe5d45d45e616bc60a2de57 (patch)
treeef8699cca7ce3773b1de747b167ceeacdc60cb92 /dev-python/djangorestframework
parentd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (diff)
gentoo resync : 31.01.2021
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest4
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.12.2.ebuild (renamed from dev-python/djangorestframework/djangorestframework-3.11.1.ebuild)11
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 68cab82be4b5..1c3a4c9b9e40 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,3 +1,3 @@
-DIST djangorestframework-3.11.1.tar.gz 804357 BLAKE2B e069b7ccf60d124281f37e5533dcd28b9f4402ab7b875ff62d3c0aed72060d0ee40c5905f09225367da91a812b3be1d4bec47343b9643380c4f583ee70d8ea98 SHA512 3063441f965a98c2bdd8279d3fc300d45af032094590b097cfe31a28fdaaf1772391ae023d5229537c1f6e7ff01405e604123bf9c665cd902a26e1cf94a8785f
-EBUILD djangorestframework-3.11.1.ebuild 471 BLAKE2B bfc61068d374ce32592c115826b2196baf570388691096f7da502e371d57100e0255fa02910cf5f2c2fc7e6489a8bdeea56d02182f2a50d4fdcc14686171e194 SHA512 ff6f4f5deb67ec915f62c619232ff577168911cdb578aa92905d5edcce569d80814b8cb28284b311cfef0889154a18614c852c325894fa2d34b2bfc860af41e4
+DIST djangorestframework-3.12.2.tar.gz 842597 BLAKE2B f450d55ade3d9d2d21bedba50c8dd6437bde383f6b30a2987a1a4fd224b6a72a03fdaf878ce72f02c2791fe2ebee02f3d9e0915d979e4f70e2f0cb9615d4a299 SHA512 d3a43212a4fb2caec27f815af0c52f3c0d2c9933febfea246429b24640b3cf23668640a4c3ddb3e3453e74a904a2b439443bb01cf24b664d19e896c353f2cba3
+EBUILD djangorestframework-3.12.2.ebuild 480 BLAKE2B c32fbf2c196aa6957fb2bc45c1b2fa979adddc29b31e67c786d960175920c4829fba201dd1757b86730f3b466daa6f42945e65b80c4d131b5c29e31f25dcbcf5 SHA512 7074d87445929e827b46944855fa193daf81dea47b741af4dd71046a5f876c3aef022db1c6aa61e32a5ab6cb4401b008f9aa7a772080346ea80db228da77db7b
MISC metadata.xml 330 BLAKE2B afda95e14e1db06af5da809e3466dcc99e4fabd85ef3b4b1c0ea9afad2e5d742eef67a46e89a915900d5d98569f5772c8977c391cc476924be51d021d0c0023c SHA512 1833829abd241267c19a2c94f54c56baac0bcb7fe478f56faea6690d8990acd35750439229f056ffe4a3059e159a732750623b317524a141d00c3cc40a52a8a0
diff --git a/dev-python/djangorestframework/djangorestframework-3.11.1.ebuild b/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild
index def354feb678..b280f1c308d8 100644
--- a/dev-python/djangorestframework/djangorestframework-3.11.1.ebuild
+++ b/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
+
inherit distutils-r1
DESCRIPTION="Web APIs with django made easy"
@@ -13,7 +14,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
+RESTRICT="test"
RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py