summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
commit2bf68d7062b64d9f815f3b8ce6942a66afe53b0d (patch)
treeac1e773aaa4d3575d18d178ae260cab963bbf64c /dev-python/djangorestframework
parentcd356b722fd8d162f02a5059fae1a66e00be52e3 (diff)
gentoo auto-resync : 17:03:2024 - 06:49:08
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest2
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.15.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 3c5ca1da1c0d..9e136b76c3ff 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,3 +1,5 @@
DIST django-rest-framework-3.14.0.gh.tar.gz 9056443 BLAKE2B 217be67f42207d72d862011a72aecef3e111c1e1dd4b4e090cae6b22dee3fb32e060f7877c498084cf1221eb960b4ca895ef55721f7cabaafe3e36ee152e17a8 SHA512 c1012c656b427e0318b2056e2f984ddc75a5b4e85f375c76fba165ad06e285848eee1bc6dc76c097daec57d780efb2551110199d62ce636a03951aec13ab4013
+DIST django-rest-framework-3.15.0.gh.tar.gz 9293419 BLAKE2B c6884185b8a11ca044956ec15bf3d31c3c46d8a911128f37ab305d89540a223e4b04ac4c13fc107333e9774ee048505f6cd0c66989f9f3cc9511239354572d25 SHA512 1b283fea0a94d64ea29bef59f18b5cb309627b7b927d80cdaad11d1fa9c4df2e2059d619ca5a73f382fa21bf847a266926542c1a1f5764bd6404d7c11861efab
EBUILD djangorestframework-3.14.0.ebuild 1307 BLAKE2B 41b40dd945007763cb9c35451b78a2b5eda5263b4cd1a0c95102cc7da2bcca09474f6ebabceb1847f79573936313865c2123b2797cf25a6062b7f48fe75d0e3f SHA512 5ac1a0b7dd41f3cc52d3ad2d356469fecd5f55053930d7ce5df9fb694a3744a14f39404fa36c2bc421bab3498fc01557e9e2d3bf783e54593fd4e1afdf830f14
+EBUILD djangorestframework-3.15.0.ebuild 1307 BLAKE2B 2fc7f227e4ae0ec70cdbb0964dfce69cd6288f8934b3a113468a3041f3d4de1b37109b45ad60c1356078b86a8135d10424d80f354d5f27792df5196351aaea86 SHA512 7dfb6ee8adeb51473c124ffa4149dcf3b3d6edef8b2a56418be6166b96d9ae352dda754b33f8872993f938177ed36942795e3fae47f9002e8ecb85c049ba48ce
MISC metadata.xml 415 BLAKE2B bb9ad83d104afc4bd68af5918b0ee30646b152c16115338e9a80ca4b6cdff52a15a9f1a7877d0964c974710b7a23401e8560ae9d621a57053cb10cd998dc699e SHA512 983ee54c8b07fa5078ce4e7fc87f1baadf540d8b5a25bbb34c1419e5892ad6c0dc518b617e02958b3dcf67aa02d24d74483917c37926f930608b83913afab334
diff --git a/dev-python/djangorestframework/djangorestframework-3.15.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.15.0.ebuild
new file mode 100644
index 000000000000..0d2c06784f22
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.15.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
+)