summaryrefslogtreecommitdiff
path: root/dev-python/djangocms-picture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/djangocms-picture
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/djangocms-picture')
-rw-r--r--dev-python/djangocms-picture/Manifest3
-rw-r--r--dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild32
-rw-r--r--dev-python/djangocms-picture/metadata.xml10
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/djangocms-picture/Manifest b/dev-python/djangocms-picture/Manifest
new file mode 100644
index 000000000000..e00a7a339ad1
--- /dev/null
+++ b/dev-python/djangocms-picture/Manifest
@@ -0,0 +1,3 @@
+DIST djangocms-picture-2.0.5.tar.gz 32329 BLAKE2B 127103b903e7268e73444d6370fae4aad10ee0a616bff47795acb2ede59fe901c54ed8fd5bac644b2f10061dce1e788dac27670ed954fc66435ee418d9660c49 SHA512 df4ba02d06966d7cee38254baadea5eeb5197557cbda1e8a202e45420881b6216efcc49fa8a6e9f9af30507a93ee2f7110e14e5ae3a645b889c990dfaca3a499
+EBUILD djangocms-picture-2.0.5.ebuild 751 BLAKE2B c0d40e8fa13192c7430a6b409860d2ec584f98298b8ac2a0d02baa6139142581ac71186ed4711951063febf3ffceb0719ea3c8d55ca271026f78bfa297f5270d SHA512 75e1f3fff1405cadeb4c336d75e51ad28d5e9fcce07f93a7b777bfaa410896d273c868f5e21220ca85ce445950a7295be49e90c4f75b93614f0a964f912bf4e0
+MISC metadata.xml 303 BLAKE2B 2eb1269bc65a3446efd89149279039e9c7a6497da0f75fe3b340641d065c4e3911adc7da32904e0f2ccec60a08704672168b8e964b8747b1f6c09135aba95e7d SHA512 8f66c2172d20eaf54fd19875d994e8aa96ef22a83868ade0c53af4789cda3fb5058b12b24932d44120237e5cedafff9e626f4d3b875821fc48f845677879d81f
diff --git a/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild b/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild
new file mode 100644
index 000000000000..68f8281a4353
--- /dev/null
+++ b/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Picture plugin for django CMS"
+HOMEPAGE="https://pypi.org/project/djangocms-picture/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/djangocms-attributes-field-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/django-filer-1.2.4[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+PDEPEND=">=dev-python/django-cms-3.2.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i 's/find_packages()/find_packages(exclude=["tests"])/g' "${S}/setup.py"
+ eapply_user
+}
diff --git a/dev-python/djangocms-picture/metadata.xml b/dev-python/djangocms-picture/metadata.xml
new file mode 100644
index 000000000000..e76677692df2
--- /dev/null
+++ b/dev-python/djangocms-picture/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">djangocms-picture</remote-id>
+ </upstream>
+</pkgmetadata>