summaryrefslogtreecommitdiff
path: root/dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild')
-rw-r--r--dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild b/dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild
new file mode 100644
index 000000000000..db4810c125f8
--- /dev/null
+++ b/dev-python/django_polymorphic/django_polymorphic-3.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Seamless Polymorphic Inheritance for Django Models"
+HOMEPAGE="https://pypi.org/project/django-polymorphic/"
+SRC_URI="https://github.com/django-polymorphic/django-polymorphic/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//_/-}"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.1[$PYTHON_USEDEP]
+"
+
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" runtests.py || die "Tests fail with ${EPYTHON}"
+}