summaryrefslogtreecommitdiff
path: root/dev-python/django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-09 23:17:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-09 23:17:55 +0000
commit8fc08491f26431ec46b36d6ebef9551f3773b96f (patch)
treed1b5bd96d856b4ddb71d02628504d39fae5c168e /dev-python/django
parentfd1ea0a53f74daa4fd860ac35a20ba1817fd20fa (diff)
gentoo auto-resync : 09:12:2023 - 23:17:54
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/Manifest1
-rw-r--r--dev-python/django/django-4.1.12-r1.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index 423c33b0d7e6..e2a121d57b0e 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -16,6 +16,7 @@ DIST Django-5.0.tar.gz 10585390 BLAKE2B 50cc715e21b046292dd86c08801b6f182c8e71a3
DIST django-4.2.8-pypy3.patch.xz 5900 BLAKE2B b7dc5c5fc162817a218ee6d025ed8a65559b80e4506e49ac393428c26e2621f9e7c5010b36f2412dea8194a9f1086ab21f97286eabd696c6a786285eb07393cf SHA512 f953b5adbd1364f1d84dde55087ccb493256b1327701275fd2fe99f3cd41751d18e002b6e21afc96892e1671428a6b8f3c2e4b88252c3c278f1a79e286bb73e3
DIST django-5.0-pypy3.patch.xz 6124 BLAKE2B 7eba7cc70b30743cf4e186a2c5b0f27c13f49114a7a80bcaa2b25fdd7a959583c115a302c9bc6da97c32f6401cf8f3616818ba759190d317c5b033a0f0088766 SHA512 c550e2b2c1243d13cd1f4908f4b6df606355d1491e3bf72042e4b4777a4474306ff0f67b1c2eb4ab4d137cc85bde52dcdbd54bec245d2ba2e092545be8a2993b
EBUILD django-3.2.22.ebuild 3017 BLAKE2B e16c0f15ab99d5d3636aac0d2e507fd52d4709b043607b929e2ff0560a4783784a1e9253ac0f73f06ce94d8cb9c35e9e986195af83c9e2ea1b893243d0578ced SHA512 03122f56b4be788d1031a4b01d6fa18bda1515fc88454ea76629325cd65c8d1abaafb02d37be1e7bec149bb28a33f69e866f7ff86a2179d7ab6923d8eca893b9
+EBUILD django-4.1.12-r1.ebuild 2828 BLAKE2B 649c3e8f77e1f19beafb795fa35e78390826f5c7520e571bafb41d297d1bffdf250a239eed368335fca985cd5ee78c4c3c17c69cc8bcb116f62da941ca0daa40 SHA512 68bc9302c3426df90a1985e494838bce679177331cce34019a84a9edf80d6ed9869ce2a352a0d58169a094c83b4a7a0fd74ff99c6ae555fa6ec7527d04341af6
EBUILD django-4.1.12.ebuild 2640 BLAKE2B 6a2b9d1f80a7a16c6b892c6cb1c242668aa3d300037662be339e2112a7ef57beb698e7887ec75d6ae480cad09efceb598b2d37d1caf6f63b06d093f861a63e8d SHA512 e4628c3bd55bddbb36d0f5364a3fada8a42547fe87eee76c076014b61e714214fee9534cb29ddb00ade89a606622f684749195165ac09e15640bbe4bc96d08c2
EBUILD django-4.2.6.ebuild 2681 BLAKE2B 74a8e4a4837d861df4d6faec7f50a24d15a24c29d39b3a8113532ef0c32b40c42bb718e898dfa5f54d8ebb41b4005ff9d5d4328fce67791ebaabca04e4bf2942 SHA512 0a51bed47ab789244e136136dcaa4508ad96eb2a4cc0816ed59b93d6d6d0ba85f8e8bcb24e818c3ef5ddea4203a2b972c1963410c48a23898e4b99af245f5d0f
EBUILD django-4.2.8-r1.ebuild 2829 BLAKE2B 2135548e518fe172772f3b6286e973428b83620de7bfd8537ab121d91308b1118c88dcf30b5994d46a125ca55c0305f06c99b8525acd19b233e514edf5c31759 SHA512 187b701a296b471187c72673d8f8783bc88bcd81c1bb8ba5ae9528df7d27f1778da9bbd43d9ab79dce34650d381bea193e92c6ea298280233e1813a1d7374329
diff --git a/dev-python/django/django-4.1.12-r1.ebuild b/dev-python/django/django-4.1.12-r1.ebuild
new file mode 100644
index 000000000000..382e7bd0fb47
--- /dev/null
+++ b/dev-python/django/django-4.1.12-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 multiprocessing optfeature verify-sig
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="
+ https://www.djangoproject.com/
+ https://github.com/django/django/
+ https://pypi.org/project/Django/
+"
+SRC_URI="
+ https://media.djangoproject.com/releases/$(ver_cut 1-2)/${P^}.tar.gz
+ https://dev.gentoo.org/~mgorny/dist/python/django-4.2.8-pypy3.patch.xz
+ verify-sig? ( https://media.djangoproject.com/pgp/${P^}.checksum.txt )
+"
+S="${WORKDIR}/${P^}"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="doc sqlite test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.5.2[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ )
+ verify-sig? ( >=sec-keys/openpgp-keys-django-20201201 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0-bashcomp.patch
+ "${WORKDIR}"/django-4.2.8-pypy3.patch
+)
+
+distutils_enable_sphinx docs --no-autodoc
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/django.asc
+
+src_unpack() {
+ if use verify-sig; then
+ cd "${DISTDIR}" || die
+ verify-sig_verify_signed_checksums \
+ "${P^}.checksum.txt" sha256 "${P^}.tar.gz"
+ cd "${WORKDIR}" || die
+ fi
+
+ default
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite \
+ -v2 --parallel="${EPYTEST_JOBS:-$(makeopts_jobs)}" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature_header "Additional Backend support can be enabled via:"
+ optfeature "MySQL backend support" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:2
+ optfeature_header
+ optfeature "GEO Django" "sci-libs/gdal[geos]"
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+}