summaryrefslogtreecommitdiff
path: root/dev-python/django-timezone-field
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/django-timezone-field
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest2
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-5.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index f5d0837383f5..712f6aa2b4b2 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1,5 +1,7 @@
DIST django-timezone-field-4.2.1.gh.tar.gz 23457 BLAKE2B 72452a21e6e086363da2ef40389d12b79860f66706e54fb9050ffe48f7fa6ad2908c75d4c7e17a79df339eac76492599dd4533ddca69a5b8757b46a36ed4b0fc SHA512 4c2da420c3aaffa23d8cdb66dbbe4b2ea8638de5a45d9e381bf9af980e52eba77fc03a2b8fee8497662199cdc9436d56543c0f6316e74ae5da68187a305c34a2
DIST django-timezone-field-4.2.3.gh.tar.gz 23605 BLAKE2B d183fb57254a6a1c86ca57558b88d5429d1d4d368c2cbf2f7a7f4d5414432fd80c5ae1df30793da185d5347afe8535dd821e7e605fb0693f26619b319894a6a3 SHA512 1a72ee557b5b527d2aeae9033c765272ebdd017d9e05708734e9bcdf6355e2747e1ce920a542dbead2d8fc6043024ece24adb3b27ccd6d0f2c8e5b3eb907e012
+DIST django-timezone-field-5.0.gh.tar.gz 33265 BLAKE2B 1d6c12ff6854463070dd6a5019cc2bfaf9514e5f6568057c684c7b061d28cc99416bac2796474fd2d884cd382e2c0e0a77883c35d4f7a7d2bb77a79255379268 SHA512 6fba9333463f1d68c0d5c6c85ad32b0106fa66be38c4e07e802222f25a0d0e024a77f36b17cb2644e89b76ea50ed667a324a9583b7b5dc0be7518ffa593335f8
EBUILD django-timezone-field-4.2.1.ebuild 807 BLAKE2B 6b9fe27cf74bf9a38679c8c78cfc92bc8d3b60839a6118546b003d2d33b120010f084fdd785f4fdf0f9932de53e6cdf077476f0fb092461afbb2a5e79ede1d0e SHA512 1f175570d95e3a7fcc0fe3cd0a30f3908bd2bced12c0bda740a5e90347887cd7689ac60bd984c07964822d0ff242d8845b8a567cca2941cc375ce3ef802c4b7c
EBUILD django-timezone-field-4.2.3.ebuild 807 BLAKE2B 318c8fd30d009fe3301b0f3e4432077b30ac6dd16331210dc27de262a0bc5a8be1d0913c7b8fa695ac57d67d84a321541af1e2d3fb8cce58b8522d8dd8f313eb SHA512 7e28684261aad0378f757b1c9914bf91aed40ec3a6705886474c7e0f4ca1d48906365f9b39d8c80a4508e7c916126516864f34299f3169d6a997eb869e2e3b67
+EBUILD django-timezone-field-5.0.ebuild 919 BLAKE2B 346642d1c6f0a65b5bea81a59aaf0eed62f2165f177efc61ef75a3507e30a6cc0c7504d65a8c730428486fae75e7e7fa367e84c6ec84ec5731a5c1d157d5aa9e SHA512 e77820d3c1fd96955282eef3caeb8b8dc4ffb6cb62fbd4c3180459a0cde8f1a7d8aade67638620bd912805c418d2ff37369c580b3c83203c3821bd7347cc7e54
MISC metadata.xml 325 BLAKE2B 481e3472db098df8d49a956b8771b6f32a7bfff8d0ab5a5d556a76c1dfbf4d393e566aed3bec7b8da37b72641f01ef34f1eeb4f5862bd7930facf517dff95875 SHA512 878eac6d1101f54284c6a33bc6458e6a9fa272dd3bc3c824f45e3c0b7b51835de2c9b80c312860e5d1dea0ca6fa1ad44b5e32d61cade7b818ffb4aa9427fed20
diff --git a/dev-python/django-timezone-field/django-timezone-field-5.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-5.0.ebuild
new file mode 100644
index 000000000000..10674e933208
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="https://github.com/mfogel/django-timezone-field"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}