summaryrefslogtreecommitdiff
path: root/dev-python/django-timezone-field
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-19 07:50:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-19 07:50:17 +0100
commit262a170a603cee433f640577f13472ab41a5d3aa (patch)
treec8cd6d9417b8a1f2275883279d2ceaedba7207f3 /dev-python/django-timezone-field
parent37cd441738bc6681ca075c01b6dd06056a27abbf (diff)
gentoo auto-resync : 19:06:2023 - 07:50:17
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest2
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-5.1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index 150c094e5c5b..71ec459b8b99 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1,3 +1,5 @@
DIST django-timezone-field-5.0.gh.tar.gz 33265 BLAKE2B 1d6c12ff6854463070dd6a5019cc2bfaf9514e5f6568057c684c7b061d28cc99416bac2796474fd2d884cd382e2c0e0a77883c35d4f7a7d2bb77a79255379268 SHA512 6fba9333463f1d68c0d5c6c85ad32b0106fa66be38c4e07e802222f25a0d0e024a77f36b17cb2644e89b76ea50ed667a324a9583b7b5dc0be7518ffa593335f8
+DIST django-timezone-field-5.1.gh.tar.gz 37449 BLAKE2B 9676bd686f7a1bfb2d7e5ee53db5ca3818a9bc20c4c759c09c6d602bcb1937098c40b9c07b3db1d7ca8af2f8882d6aaa333f325e422725e3ea7303fc60e9b59c SHA512 518e16b092af00edae9b2488fd4e9380a661864e9f2d2d3ed8ffc6d9188831d4a7b79ed81d553bc41089ac8cb6fab760339af668ce7c2c0218d991b77306c50f
EBUILD django-timezone-field-5.0.ebuild 836 BLAKE2B 83e8c92ec024f2c6e8f480c0bc63e82113bddbc59604b528f89dd1c42bbf5d48fbc6487f414faedbb5425aaf1dc9c378c6ecdd780b4535568d1c1bcf28842082 SHA512 a72fba7e0c961616d47d07ae750b59cd71375653b06157e8e26f68cc1e0d5dbb47fcd6bc9c0a12d9103c92254bef475c2f3e6be06e40a42ad15517d7ee092ee2
+EBUILD django-timezone-field-5.1.ebuild 931 BLAKE2B 2dbe3f57ba08a4b6f3eac34b73a4aa0d856893908162f6f647bc0519139005f39b4a1bd26d96c81cfd0588740a82d3944533eddfb09bf4b4fd29b3fad42abdae SHA512 d0f03f584e1ccc22c9e2f5a3bddbcc366eb8fc098d96a091187866a548c2207f6f29ab5af44042baedb3237059f035a8d712c5ca1bbc9f68e6d30cbe4c1aa044
MISC metadata.xml 417 BLAKE2B 8169aa146e3ea17598ed401420f9504deccb4fdf4faea57678073d7fcbf7cf4062aaf4e00d4c2eb80a29276b298b144d013b8baedc8b5277ff30bc65dff4f8c4 SHA512 09c5d7dcbf44b72631d63dcbc98e4dd203c28f24ffb5d5e833f6c36e641b4360b096ace62e12faff182fc26fd60fd5f4f9eb3ebf3e463fd0d1afc66fe9a70e6f
diff --git a/dev-python/django-timezone-field/django-timezone-field-5.1.ebuild b/dev-python/django-timezone-field/django-timezone-field-5.1.ebuild
new file mode 100644
index 000000000000..e445e9112a8e
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="
+ https://github.com/mfogel/django-timezone-field/
+ https://pypi.org/project/django-timezone-field/
+"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/django-5[${PYTHON_USEDEP}]
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}