summaryrefslogtreecommitdiff
path: root/dev-python/django-taggit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/django-taggit
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/django-taggit')
-rw-r--r--dev-python/django-taggit/Manifest2
-rw-r--r--dev-python/django-taggit/django-taggit-2.1.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/django-taggit/Manifest b/dev-python/django-taggit/Manifest
index 1a6dc3207494..cd1130dd717a 100644
--- a/dev-python/django-taggit/Manifest
+++ b/dev-python/django-taggit/Manifest
@@ -1,5 +1,7 @@
DIST django-taggit-1.5.1.tar.gz 52766 BLAKE2B 59892ba591ad5cbc40a7515a6427722d7cb58e2daadec579b1c08dcc3522e24e041cbe06c953c3717cdf3db50aef7ff9fb5b4eac00344e457b61797745638107 SHA512 8e7afefd8f0654340e234f7bd1cc3684b3e5d1f4d94d17c79ed8fb82096c21a809e7f8db2fea9509d45c3f2bdc5e8ed52fb0823779b0a039f87528642803725b
DIST django-taggit-2.0.0.tar.gz 55042 BLAKE2B cb4d3c8b32ba524eb0c59b447155b818c30ed77ec95a76c7412bccf109d421f2628fb40c8bb65d2c845351c8e8ed77605c0e5d77ac1ddcff6cddd5248f2fcdc6 SHA512 9cffde5a0de170e08ff93b245873b02a4868e67ea946c6b9997b782fecb8f71418dddc702ca283d45e8c1685a4a45143aa6c726de187410b9a89afe2efadd190
+DIST django-taggit-2.1.0.tar.gz 55659 BLAKE2B 343176e910743924d7b84ef827b4a63e0bc4bc3db7d7c3ed8e7319b18713bc5cdb1e58f1a9f7356a01c1ae5c47daf561e9e68484f0bd40aaf03c780f8558b55c SHA512 64ac21574ba4b0e7dd8d52dee910350d7cfc2f821aaadf7767a4b74d4db7ab69d704558dac13dd68dc29e985ab593bc4189e1d064c0a0d4fe6fa7ab88038d353
EBUILD django-taggit-1.5.1.ebuild 651 BLAKE2B 30cf35983a6d700460559c4a2da3839798407d7b961ffaf1063917c7e24816ed10f42d0fca5d5ea592513cf8a106587c14360e0365c982b94ac508d354f75e36 SHA512 3841045ce523b27828a91d0da10b2deb7e79cb434ce99f40d21dc0eae4a1dd9ce14cf3ffc15410661cf1745072827f051ccafccff98d5288af2cc2931a7dd95e
EBUILD django-taggit-2.0.0.ebuild 652 BLAKE2B 110cb5144d495c69b5c47beb0cfa321f950bbcb32642f90b7236a0d240da3f4659e092e269395cc370cc0dd5ff64d5fedf1b27f19c1bb267b8c0ae1249578ab4 SHA512 ab1ae9024eac7e2cad37d1bb733dcdea9b3584f936b5a18881ebbe83cbd2d289e87d032830866aa226fa1095ddf0fc98f33482376d58fd40a16ee9f865ad19f6
+EBUILD django-taggit-2.1.0.ebuild 682 BLAKE2B 011002bfc6f335f25a377ed251ca19b5c025b1fc6c2c309b668de0c0d669d962c5bf704edc4707a59d4bb30689f4f368b3e0a68ec0e4339cfceb16acfa1514e9 SHA512 fa5bbf803f19e69237c964449eb885a4997b5be059fa7eaf0c9dce14c3ec65a23438e6afc3d02f7b649850aa7042a3d3756a3b1c8dbf58e616ce396442ee1a00
MISC metadata.xml 341 BLAKE2B 4cd13e0c8330dc284424e011d573fc640a1af5804063c2a198b5eb95aecabba032936a477af38338f7edfefbc7e9fa3b2761c2bf7d132fa89202b36f24a64eb2 SHA512 6007ed469c39d331f190c107b3e9cff6ff6a80c9c7a7653410ad7b1fbf0f34d948b0a04ef00ff0ab51650d5d18a8dd277bac40c44354345d0f69e4ea45519d50
diff --git a/dev-python/django-taggit/django-taggit-2.1.0.ebuild b/dev-python/django-taggit/django-taggit-2.1.0.ebuild
new file mode 100644
index 000000000000..11dbb8082eca
--- /dev/null
+++ b/dev-python/django-taggit/django-taggit-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Simple tagging for Django"
+HOMEPAGE="https://github.com/jazzband/django-taggit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings=tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}