summaryrefslogtreecommitdiff
path: root/dev-python/django-tables2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/django-tables2
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/django-tables2')
-rw-r--r--dev-python/django-tables2/Manifest2
-rw-r--r--dev-python/django-tables2/django-tables2-2.5.2.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
index 72e31a54564d..0b1a1aa36732 100644
--- a/dev-python/django-tables2/Manifest
+++ b/dev-python/django-tables2/Manifest
@@ -1,3 +1,5 @@
DIST django-tables2-2.5.1.gh.tar.gz 430778 BLAKE2B 7811880ec49a514b74252d32fbc59d800aaa34fb2bf4af5675d1c4555c7a52f9eb3ca67d8d940697146c07de1e42006c6d3880a53b31a386bd088aa6939b056f SHA512 baf955b255dcbcf09250cfdbb2dc1fb51f3f9142ad29bf4ca8888344d1bcbe9f23a59f1509cad7e847d82bb6d410a494ed9eae1d4d4ca633e7f0351e4a98839d
+DIST django-tables2-2.5.2.gh.tar.gz 430733 BLAKE2B 70aa25ca949e4244a089894a26e384d5fbdd77cc5f7b939c9fd594c70114dafd0b8134d8327d247c1272159f278c54c980a5363ad86c75af95b4ffed489468cb SHA512 0a3522cd7500e09bfbe1dd4ee102542f9e6361163195928b2d8ea301133b39aa8d417bba29b93a6166b79b744fd58889af8ae8eb49bcc2251c21dd8b9b64827e
EBUILD django-tables2-2.5.1.ebuild 1084 BLAKE2B 7a0f1e7e6b9a1f54abe8e967055c066aa191b22d769e0b975acbd29a50f4c1307e6494b611fcd53802edba513917cce3eef860629b57499604b4b941bacd4312 SHA512 8b8a600397fd996f5292cb8ead46e36a04b2c86bbc12f3a3f3aba1c36c9e836a3528b6b1135e604f963b69b46489db03ce1b969fdd5666292526dce169c438c8
+EBUILD django-tables2-2.5.2.ebuild 1084 BLAKE2B 7a0f1e7e6b9a1f54abe8e967055c066aa191b22d769e0b975acbd29a50f4c1307e6494b611fcd53802edba513917cce3eef860629b57499604b4b941bacd4312 SHA512 8b8a600397fd996f5292cb8ead46e36a04b2c86bbc12f3a3f3aba1c36c9e836a3528b6b1135e604f963b69b46489db03ce1b969fdd5666292526dce169c438c8
MISC metadata.xml 416 BLAKE2B f63a86611d3d5805c63f14c75851d6283f12777fce462a796c205ca4141fd5d5a321a7173f2b8bda70d67a3db5935864ca632e6858757626ed632fe3ec6874fb SHA512 1cf202a6a5fcbe86157ba8bf71f5c0c8df2c4393dcc955b2ad37e4f2164a33e241287bed237116df298e6a062a861ec99f3326d13f8f5845891556eb36d9bbf3
diff --git a/dev-python/django-tables2/django-tables2-2.5.2.ebuild b/dev-python/django-tables2/django-tables2-2.5.2.ebuild
new file mode 100644
index 000000000000..823847d534f7
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-2.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-tables2/
+ https://github.com/jieter/django-tables2/
+"
+SRC_URI="
+ https://github.com/jieter/django-tables2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/django-filter[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # these tests require tablib
+ rm tests/test_export.py tests/test_templatetags.py || die
+ # these tests require fudge
+ rm tests/test_config.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" manage.py test -v 2 tests || die
+}