summaryrefslogtreecommitdiff
path: root/dev-python/django-tables2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 07:37:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 07:37:01 +0100
commit1a39e197a344b8ec7e3ed6c173bdf2a1ccba5b6b (patch)
tree7e7d76b763f13b5096b3bbb3b164edc87dc72b27 /dev-python/django-tables2
parentdab47ccc26a61cb1fa68f2ab787233a1d12af4d1 (diff)
gentoo auto-resync : 28:06:2023 - 07:37:01
Diffstat (limited to 'dev-python/django-tables2')
-rw-r--r--dev-python/django-tables2/Manifest2
-rw-r--r--dev-python/django-tables2/django-tables2-2.6.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
index 00b4eff1598f..3cb9cf36f771 100644
--- a/dev-python/django-tables2/Manifest
+++ b/dev-python/django-tables2/Manifest
@@ -1,3 +1,5 @@
DIST django-tables2-2.5.3.gh.tar.gz 431016 BLAKE2B 5564cd1ea19ffd7de83f949103bb5a56f987efd1e8a0cb356a0455c2244118b60c7ef78eb8fc7e57e023007046c51b4717470ee3542e1ed8a84b65e481455e75 SHA512 61b79e9fd8c2ea69afe88d7f2dd7f7015e53a6b68800c769106214bbc5818bc4f5b30eebe2d190cd6cc3a36686978befcc9b88fb4a0a7930f5bb37c608345e30
+DIST django-tables2-2.6.0.gh.tar.gz 431368 BLAKE2B 56896a416599e6f4293202ca945bf808c99ce08c4b5f53848919c3a32590e18d867e694fe7c989fdb855a5cdaf94350199c65735078c0d312d1f4f0a556ed9ae SHA512 29cabb777ed102dfde4d24836c5952bf892c7c8e3c5e5f608e00fd1aa4eecc33c6a2b1be1fd07617b354d7de34215d501592c53033d6f48c29e89ab68fdcb22d
EBUILD django-tables2-2.5.3.ebuild 1084 BLAKE2B 7a0f1e7e6b9a1f54abe8e967055c066aa191b22d769e0b975acbd29a50f4c1307e6494b611fcd53802edba513917cce3eef860629b57499604b4b941bacd4312 SHA512 8b8a600397fd996f5292cb8ead46e36a04b2c86bbc12f3a3f3aba1c36c9e836a3528b6b1135e604f963b69b46489db03ce1b969fdd5666292526dce169c438c8
+EBUILD django-tables2-2.6.0.ebuild 1085 BLAKE2B e6afb5fd22a14086f3544b612abc668b5743eb93f0664d604d659d001f6d1498c58f9f34de5ab0f2da65eb21945196b03accc34171742b9838ba407f29ac73c1 SHA512 01f544d4a406c900ba26fb96c2189e69d8b480f6b455650c2bf4091bf43fddfb229a31d4f81de7fa3cce751126a5f4ca7a21bca0110230f33141761a23fc1879
MISC metadata.xml 416 BLAKE2B f63a86611d3d5805c63f14c75851d6283f12777fce462a796c205ca4141fd5d5a321a7173f2b8bda70d67a3db5935864ca632e6858757626ed632fe3ec6874fb SHA512 1cf202a6a5fcbe86157ba8bf71f5c0c8df2c4393dcc955b2ad37e4f2164a33e241287bed237116df298e6a062a861ec99f3326d13f8f5845891556eb36d9bbf3
diff --git a/dev-python/django-tables2/django-tables2-2.6.0.ebuild b/dev-python/django-tables2/django-tables2-2.6.0.ebuild
new file mode 100644
index 000000000000..3db8a9bb8dd1
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-2.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-tables2/
+ https://github.com/jieter/django-tables2/
+"
+SRC_URI="
+ https://github.com/jieter/django-tables2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/django-filter[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # these tests require tablib
+ rm tests/test_export.py tests/test_templatetags.py || die
+ # these tests require fudge
+ rm tests/test_config.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" manage.py test -v 2 tests || die
+}