summaryrefslogtreecommitdiff
path: root/dev-python/django-sortedm2m
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
commit99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (patch)
tree9bf7a2d385aace0ea5f3f8d3e3657168b758fdaa /dev-python/django-sortedm2m
parent39bccce90513402ec93bb0fde30678f16b07a9cc (diff)
gentoo auto-resync : 08:07:2023 - 22:23:22
Diffstat (limited to 'dev-python/django-sortedm2m')
-rw-r--r--dev-python/django-sortedm2m/Manifest1
-rw-r--r--dev-python/django-sortedm2m/django-sortedm2m-3.1.1-r1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-sortedm2m/Manifest b/dev-python/django-sortedm2m/Manifest
index d0af025616a3..2b392f983a9a 100644
--- a/dev-python/django-sortedm2m/Manifest
+++ b/dev-python/django-sortedm2m/Manifest
@@ -1,3 +1,4 @@
DIST django-sortedm2m-3.1.1.gh.tar.gz 45888 BLAKE2B 878a23d5f5dad114b0b6ef9bd687d4e23620c823a8ad33a66b7c6c1e598db15e5328a46373dd6d7fd9449b4ba533e21664db716cde40150af2451a74f2f28fda SHA512 440c049a1fbe54c0db8edb0a5a737b5d84553afb7305d21a64c2dbac02f143e6f17e7e0499a4d3e687b13f292558d7818c030d78d8cc9443048a95ae6b50204f
+EBUILD django-sortedm2m-3.1.1-r1.ebuild 931 BLAKE2B cf54cb3161bcba6606d37aa2825aa7d3cf1810533bb20e40746b687b0b2a46ffb5d5e52089ce442968434f9868e2afe6abf0b935089e630fc94c72c283f40df8 SHA512 3dc85023298503d37f8924b676666e1abc810c1123f11ef44e356d942476cda6169005e55cb6cb630e3ea00678a3bd3910068e90c4629e7bc087125462ff2317
EBUILD django-sortedm2m-3.1.1.ebuild 888 BLAKE2B 3307a3a3606d2c8b0e9b6350f29126a0bde2276877cdef39fab79b93d0d932ae475a49e41750b7d21259f853fea46d642cd822f737fe08c489d9718170db9296 SHA512 ecd0370f51017fc5fffcf9644f7d04c4732dcb335882f9ba0edb5181800ed84a416aae32c9ab28c76b10040a4e6ea58e12a2dc2409594958e31463955e6ad2b3
MISC metadata.xml 385 BLAKE2B be4400699a7c6efbd3ad0a115416e7fa7e7da396e8d5b5c24da131866a747c6b225c753e0a092082a4c0bdf6b067a070a204cbc66f2d573fe075b42013537ef0 SHA512 735bd3eae6c3083743b9ddf5af2a567bbf7a76f5a4c2d44b1bba74017ac9dfd2ed41ad86e448d851533c95cbf49b25d8ca13c7245ff0fd049d949083211d8ace
diff --git a/dev-python/django-sortedm2m/django-sortedm2m-3.1.1-r1.ebuild b/dev-python/django-sortedm2m/django-sortedm2m-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..13fb9a284421
--- /dev/null
+++ b/dev-python/django-sortedm2m/django-sortedm2m-3.1.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for django's many to many field with sorted relations"
+HOMEPAGE="
+ https://pypi.org/project/django-sortedm2m/
+ https://github.com/jazzband/django-sortedm2m/
+"
+SRC_URI="
+ https://github.com/jazzband/django-sortedm2m/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test_project:${PYTHONPATH}
+ local -x DB_ENGINE=sqlite3
+ local -x DB_NAME=":memory:"
+ django-admin test -v 2 --settings=settings --noinput sortedm2m_tests ||
+ die "Tests fail with ${EPYTHON}"
+}