summaryrefslogtreecommitdiff
path: root/dev-python/django-registration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
commitd83532aee7e94505bf23da29e6224ca164aac759 (patch)
treefcd6dbea91816dd541b6c602b5fed02ca574a5f6 /dev-python/django-registration
parenta2844b413d00a2859401e017a0311986151e1594 (diff)
gentoo auto-resync : 16:04:2023 - 17:51:01
Diffstat (limited to 'dev-python/django-registration')
-rw-r--r--dev-python/django-registration/Manifest3
-rw-r--r--dev-python/django-registration/django-registration-3.3.ebuild27
-rw-r--r--dev-python/django-registration/metadata.xml12
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/django-registration/Manifest b/dev-python/django-registration/Manifest
new file mode 100644
index 000000000000..44f76ab99e8d
--- /dev/null
+++ b/dev-python/django-registration/Manifest
@@ -0,0 +1,3 @@
+DIST django-registration-3.3.gh.tar.gz 77483 BLAKE2B 4d65479983a5aa104daffe07ed84218250893ccf6df44e5533473d587a6e76fe71c905124af3909efda515ea84df49f27eafc32f23480ca3e1f6ef55607b3cd7 SHA512 66ef0de4c1adb303717cf87e9d3ce7ab07ca60bab64cbc810f61f31d05a968c0b4fa216b90e7ad575e647c6fdb789ea875c428b0ca8b0104d055ed0882aae144
+EBUILD django-registration-3.3.ebuild 630 BLAKE2B 5e1bbff742b62c27b6ea4dae4fc2b8d46567766caec6d2c48c59c54d5f08741456c3a5183742f8527f57a9fd661a05396027968001b7947bc7afc2a2863ccac2 SHA512 645ae2994ed57d0084597d7b29a1e5c2d72e8d2d4003027294e775a285004f84f9e46dd4385397a54bc1da97a24d71a0a396f7ff4dd01d925f04ac79c13c2509
+MISC metadata.xml 401 BLAKE2B 695741a0b4b269cf5f259a00fbfa4527872aa396495468b9996a78be679238fdf67986185cb00dd616d048a6ce5d4aa9525b99dbe1af4c980d5caa9bc6936368 SHA512 79fe2b9fe95515d02be6b910273228c9b9b63e598ed1868be6e3c7895562db1362b9304bf9858c76fb3e6c7efc8bada88f2a74c756b72a024ff171fd425ca761
diff --git a/dev-python/django-registration/django-registration-3.3.ebuild b/dev-python/django-registration/django-registration-3.3.ebuild
new file mode 100644
index 000000000000..385e2ce8ccb0
--- /dev/null
+++ b/dev-python/django-registration/django-registration-3.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="user-registration application for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-registration/
+ https://github.com/ubernostrum/django-registration/
+"
+SRC_URI="
+ https://github.com/ubernostrum/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # Tests are not working here
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/django-registration/metadata.xml b/dev-python/django-registration/metadata.xml
new file mode 100644
index 000000000000..399da25e9adf
--- /dev/null
+++ b/dev-python/django-registration/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-registration</remote-id>
+ <remote-id type="github">ubernostrum/django-registration</remote-id>
+ </upstream>
+</pkgmetadata>