summaryrefslogtreecommitdiff
path: root/dev-python/django-q
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/django-q
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/django-q')
-rw-r--r--dev-python/django-q/Manifest3
-rw-r--r--dev-python/django-q/django-q-1.3.3.ebuild25
-rw-r--r--dev-python/django-q/metadata.xml10
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/django-q/Manifest b/dev-python/django-q/Manifest
new file mode 100644
index 000000000000..eb6fe3842bf4
--- /dev/null
+++ b/dev-python/django-q/Manifest
@@ -0,0 +1,3 @@
+DIST django-q-1.3.3.tar.gz 53997 BLAKE2B 5881fc5b49ef1a58973ca91f0aa3756393ff45714cc3c080292414337a950041563e075401b522726a4fe17e5535a9a428df82dee7bd52a88d4aa1dbdc5373d6 SHA512 469fe359c9c25d8e3d3a8141c7a4a23caaf0e3b127fc5d8b5c70cb2dbb6be5b8ddb0476773c3b919b1fae6f996ba3e423889830c364715edb87f37e2a69cde1b
+EBUILD django-q-1.3.3.ebuild 624 BLAKE2B bfe5fa94bdb78de2ba08ad9bdbe4f4d43d856fae6c97c4ff15483628ee2180e1064b0d6abefc2d8135dca62d8bd775c4dc82fcc895a903343e1fd4af0b86cd5e SHA512 f3aa03af3db8b55131cb0c5e17f8d61a6a4f6fff799d77ec247b43c0545b945954c0eab10f4ccf3bead8b5cb9de0af92c81dc30c3fab7c43ad05251c7ebb08e5
+MISC metadata.xml 287 BLAKE2B 7c43bbdf6ffef372dc4c71b7cb7c0a45674c0866bddb8469fe341bb4a738870f4811d4a50b2868b9fafe7d8a44a65dce297ee8f7e304ea967a41814bf3fe5544 SHA512 e9de0782c51999c9fab825ad3d5292b52f842ac62fb78494c232f5a961baf8286d346ee40870a4bafaba9ab2e01480adcd62de8431747801400b8ce46d7d7a44
diff --git a/dev-python/django-q/django-q-1.3.3.ebuild b/dev-python/django-q/django-q-1.3.3.ebuild
new file mode 100644
index 000000000000..75edaad95a9d
--- /dev/null
+++ b/dev-python/django-q/django-q-1.3.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A multiprocessing distributed task queue for Django"
+HOMEPAGE="https://django-q.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]
+ dev-python/django-picklefield[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/arrow[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst )
diff --git a/dev-python/django-q/metadata.xml b/dev-python/django-q/metadata.xml
new file mode 100644
index 000000000000..63a3a0456e84
--- /dev/null
+++ b/dev-python/django-q/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-q</remote-id>
+ </upstream>
+</pkgmetadata>