summaryrefslogtreecommitdiff
path: root/dev-python/django-prometheus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/django-prometheus
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/django-prometheus')
-rw-r--r--dev-python/django-prometheus/Manifest6
-rw-r--r--dev-python/django-prometheus/django-prometheus-2.1.0.ebuild (renamed from dev-python/django-prometheus/django-prometheus-2.0.0.ebuild)9
-rw-r--r--dev-python/django-prometheus/metadata.xml1
3 files changed, 8 insertions, 8 deletions
diff --git a/dev-python/django-prometheus/Manifest b/dev-python/django-prometheus/Manifest
index abb8475b72ed..bfdcebe21f35 100644
--- a/dev-python/django-prometheus/Manifest
+++ b/dev-python/django-prometheus/Manifest
@@ -1,3 +1,3 @@
-DIST django-prometheus-2.0.0.tar.gz 20028 BLAKE2B 272f192cc0ee4492fa6dbbb65ba6696fdf8fbddc0724290d9b55e5aedb740c2c92cb609969240004b4faca4569580ab451284c2f4bbde589ee61bb96ec448ff3 SHA512 8345c23c8032f0dbecd8e801bd6673e7e3804003ebee0a15b0c8ce3b2d4c6b6f47e7c41e33df2b18a0497eb453972d8b231b88fb51184fafc58d306a9430fdec
-EBUILD django-prometheus-2.0.0.ebuild 567 BLAKE2B f991ad45c52354f80430aa081da878c1ea0d70f8bf60bafd580e0a0ce0fbbfb946ff71220f9be1b0353dc533474fbc1d229704b99639bb89125c61e84508ae57 SHA512 0b9e8cd81488dc96bc4fc532a0000377a956c1912261617cd1aa30d10b961ae64cb0a1c6eff1ddbecf4863a2df71b6c9c2d04dd08163e8a397501131858da112
-MISC metadata.xml 328 BLAKE2B f53fb884836d43f5e5d68795b2905ae77d981c422c3a9326cd749533a33f870dda6a13a1946cca6cc0dcc53361303af3b820bca99c10cdd84643a6733347b24b SHA512 5e4ea2e04845f17b63d889c1436562589b6d02e199e5eac61adccefcace9038ef58c6b5934b10e1bb057b575795580dd73a557cea20cdee8f8185f6a3ae2d3fe
+DIST django-prometheus-2.1.0.tar.gz 24615 BLAKE2B 381aa345fac29e71e2b883fb485dce1d6ca3f13fc863d6ca9a62d5cd8f605f8cca727fbc3a3946e707d80f89d7fbaf544610cfb4857a45bc3dc13eeb22aeb4d6 SHA512 0c102467b99df409e31f99fb77d16558bd01c9c11f04ac0f80b59e486bc6e03979e16785083980c43ee3caad26b7a6bf618f9592fcca788ec2793a30d6b44241
+EBUILD django-prometheus-2.1.0.ebuild 553 BLAKE2B ab968f4e704555898fcf45ae2054cb2cd9c2a11338389fa8d730a65f21cdbbbca67a9cf511b6dfac54b10d3be5140632d069b7b4433b4f6f5cf3ff952b779072 SHA512 311687ee5cd990b6fc405ae873b02d1cf3ed36d3da269bc07cdf52df7d086039a82827a9a8c5ee470fb9d131a54782d690c0730a0b0f6786a572fa9104408f33
+MISC metadata.xml 352 BLAKE2B 4b1164a17399f32e071ee491334ffaea3bc09b2214de7c5bd05d3e0986ece1803a428bfd53af528009266ca836d5855df4dfeed9fe84059d617e6373d4296b7e SHA512 4295d46ce2da93c97b4f540a8ee85cb4a742c6c0499e4dd21d3e684125711e5d6b5e0f47c89de5e44a05d5373369db6ba353635a6af64cdc92dc19b00d7575e2
diff --git a/dev-python/django-prometheus/django-prometheus-2.0.0.ebuild b/dev-python/django-prometheus/django-prometheus-2.1.0.ebuild
index 0ee0b8e679db..108c87dc5cd3 100644
--- a/dev-python/django-prometheus/django-prometheus-2.0.0.ebuild
+++ b/dev-python/django-prometheus/django-prometheus-2.1.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
-DESCRIPTION="Library to export django metrics for prometheus"
+DESCRIPTION="Library to export Django metrics for Prometheus"
HOMEPAGE="https://github.com/korfuri/django-prometheus"
SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
@@ -14,8 +14,7 @@ LICENSE="Apache-1.0"
SLOT="0"
KEYWORDS="~amd64"
-DEPEND=">=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND=">=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]"
python_prepare_all() {
sed -i "/pytest-runner/d" setup.py || die
diff --git a/dev-python/django-prometheus/metadata.xml b/dev-python/django-prometheus/metadata.xml
index b4bca3123fc1..6d36a86afae5 100644
--- a/dev-python/django-prometheus/metadata.xml
+++ b/dev-python/django-prometheus/metadata.xml
@@ -5,6 +5,7 @@
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">django-prometheus</remote-id>
</upstream>