summaryrefslogtreecommitdiff
path: root/dev-python/django-polymorphic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /dev-python/django-polymorphic
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'dev-python/django-polymorphic')
-rw-r--r--dev-python/django-polymorphic/Manifest3
-rw-r--r--dev-python/django-polymorphic/django-polymorphic-3.1-r1.ebuild41
-rw-r--r--dev-python/django-polymorphic/metadata.xml13
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/django-polymorphic/Manifest b/dev-python/django-polymorphic/Manifest
new file mode 100644
index 000000000000..5a08bc67ff9e
--- /dev/null
+++ b/dev-python/django-polymorphic/Manifest
@@ -0,0 +1,3 @@
+DIST django-polymorphic-3.1.gh.tar.gz 104090 BLAKE2B de2a2b38f338a10198d00e70d1813e541bf627e2ba2f5e29f0844c9ec7034badba39c077a195fc8c2f71105f1b4e546b91218b95d2ac47020f0dc2e3a5b0baa8 SHA512 730f617009007f94e935870941fdd8973d0cd5995060afbd138622345de77fa48bf2afe037bfa2ad476cef0a31e90cab1eb55109c470ae815a98e1facfa8f125
+EBUILD django-polymorphic-3.1-r1.ebuild 822 BLAKE2B 8a4cd6a9175bd7693ace73861005333a731327eeeb8734c2c560bd7e4d26bba1ff15b6ca4c9c9416e5d6e8b7991668b2b8dea0ce5102dbcc29cd1c111caafb69 SHA512 1d5469ad32dc4f2b66ca496d562a746d4b7a2cebed779fdba1595905a5ce1c8d7a83c03b6e6ba3211e3c13080ccf36099790684c43a3cf7cbf76d8617c514045
+MISC metadata.xml 413 BLAKE2B e8f8445ce135557d92f29082672c571a96325763cf5bd92908cb3c7ad6744190d2f33dbf7a679ac5443dfac116366b3b91b8ad47b3c487fded657c55a00d8236 SHA512 157637720cc89bdd332c0d2cc1a338a119b0372a426de41998df3e78add121423ad4a94f10e0e7ffca1a3185c7a4cde709385756cc009de86d790851fdd4ca87
diff --git a/dev-python/django-polymorphic/django-polymorphic-3.1-r1.ebuild b/dev-python/django-polymorphic/django-polymorphic-3.1-r1.ebuild
new file mode 100644
index 000000000000..9f7d8b0b2c6e
--- /dev/null
+++ b/dev-python/django-polymorphic/django-polymorphic-3.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Seamless Polymorphic Inheritance for Django Models"
+HOMEPAGE="
+ https://github.com/jazzband/django-polymorphic/
+ https://pypi.org/project/django-polymorphic/
+"
+SRC_URI="
+ https://github.com/jazzband/django-polymorphic/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.1[$PYTHON_USEDEP]
+"
+
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" runtests.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/django-polymorphic/metadata.xml b/dev-python/django-polymorphic/metadata.xml
new file mode 100644
index 000000000000..007d21b86f5b
--- /dev/null
+++ b/dev-python/django-polymorphic/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">django-polymorphic</remote-id>
+ <remote-id type="github">jazzband/django-polymorphic</remote-id>
+ </upstream>
+</pkgmetadata>