summaryrefslogtreecommitdiff
path: root/dev-python/django-pipeline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/django-pipeline
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-pipeline')
-rw-r--r--dev-python/django-pipeline/Manifest3
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.6.0.ebuild53
-rw-r--r--dev-python/django-pipeline/metadata.xml11
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/django-pipeline/Manifest b/dev-python/django-pipeline/Manifest
new file mode 100644
index 000000000000..87869779ac57
--- /dev/null
+++ b/dev-python/django-pipeline/Manifest
@@ -0,0 +1,3 @@
+DIST django-pipeline-1.6.0.tar.gz 41822 BLAKE2B 4917c527103522114b31afb0e9dbdcb202b0181d6634eaa4baac632a05c0ecab4502a3d4e13e97413268db582833df71f3f6df088b07ae8a354574331d2a9026 SHA512 4cf89f34a56aeb7cd5042617c265fb4bccfe7a0c32c26d50a0820d35c18207cdbf68b43e8f51ef7145fc48576ae0fe0a21553a75ec8a0a21a3c62e7699268d73
+EBUILD django-pipeline-1.6.0.ebuild 1440 BLAKE2B 49079a88f2adbab349f8ba4daa980be6b6eb31591b435120fcf260ba156dd6a9287b682fadf245b0ebd117fd370ca2d018934ba9931708c33cf2fdf0c98bb282 SHA512 d1804d0196b170305ad40bc2c7059fcf8e83312cdb867a6c77be2af51da737298613f3b468d7f1252992a36521edc4dbcd752513c287f9a13db3d7f8e3a3946d
+MISC metadata.xml 341 BLAKE2B 63efd8486a9e20bc6a8f085295595e8c3cbc389bb3c0153ecd6ccff6c17835f00cab2a34a22005148d84e0e900d3f6f6bff055a6c691eb83d014e459654798e9 SHA512 7cef597f45253dd0e25392fbb3bd20090ef6a522d506380be2a925948275bbf2348c5d114f84020ad132e84c72d2dd125fd487d591eb33d45a137d0be215ff09
diff --git a/dev-python/django-pipeline/django-pipeline-1.6.0.ebuild b/dev-python/django-pipeline/django-pipeline-1.6.0.ebuild
new file mode 100644
index 000000000000..d190d7f179cb
--- /dev/null
+++ b/dev-python/django-pipeline/django-pipeline-1.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An asset packaging library for Django"
+HOMEPAGE="https://pypi.org/project/django-pipeline/ https://github.com/cyberdelia/django-pipeline"
+
+# PyPi releases lack docs/ subdir:
+# https://github.com/cyberdelia/django-pipeline/pull/254
+SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/django-1.7[${PYTHON_USEDEP}]
+ dev-python/jsmin[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+# As usual for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/cyberdelia/django-pipeline/issues/381
+ PYTHONPATH=. django-admin.py test --settings=tests.settings tests \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ export PIPELINE_JS_COMPRESSOR = 'pipeline.compressors.jsmin.JSMinCompressor'
+ distutils-r1_python_install
+}
diff --git a/dev-python/django-pipeline/metadata.xml b/dev-python/django-pipeline/metadata.xml
new file mode 100644
index 000000000000..df6b94927396
--- /dev/null
+++ b/dev-python/django-pipeline/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cyberdelia/django-pipeline</remote-id>
+ </upstream>
+</pkgmetadata>