summaryrefslogtreecommitdiff
path: root/dev-python/django-otp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/django-otp
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest2
-rw-r--r--dev-python/django-otp/django-otp-0.9.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 2bc8c05b73ca..192cefddbf45 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,5 +1,7 @@
DIST django-otp-0.9.0.gh.tar.gz 60204 BLAKE2B c71b27e007580410fea3cf8110631801c8c08f7e325c3586cb5a41a9618b371b5d65e3b030a5b483cb6cda684fe837cd40aa1c5d04f54dc82cda750b8ba8aeb9 SHA512 dd3c99e928ebf1ba5b6f6b2f34fcf8a1f86ad64ece17a9bd97c56be239f165808f6d1025e2826a12a8eadc150fe49920a0b7ef398d83542cd97a4a6f391505fe
DIST django-otp-0.9.1.gh.tar.gz 60230 BLAKE2B 1a912e35f8245d3411fc1a9b26dd53d99df5dba5f2a5f68003bc4d535365af336d8664f81cc42f140247bb0e7150c0a60a3308d96cda1e41681dc93520f112d2 SHA512 600286653c035527a2a7978f19c3b9683805ab4562f12afcc2140adf92705239b8f9141b9979a6c30110cf7f3cc13c67019f39448d3cb8db61c4e1b0cdbcee88
+DIST django-otp-0.9.2.gh.tar.gz 61366 BLAKE2B 5016e352db2cfd60d94cd38986185fddab84bf997b72ff5ec3b59cc5944afa74ef67deca7691fd78e28f2aa75bccb9b976707ab6822a6781e541157d4810d8cb SHA512 9634ab23d006d768cec8f3a6685a77e54f8bee89854af2d431eb99560819139518738eb9f1a124190633dbd99f47388f5fa9685bd199a0918f73b263894ea051
EBUILD django-otp-0.9.0.ebuild 765 BLAKE2B ece769006ba4a4f8ead9ee89cd15224526bf8f21ece4155b84f05fea4dad1009da5225571c2b5171fbea013153c844ce8c22c36cfc738171739d2777d5d3ea6e SHA512 8b151507dc42dbc5d82be55ba8290bdede0703b49fc4d03109a4264362d04e9f3fddd9a60212fecb5906ebec9f75359e01038363db045389508e151b1b4861f5
EBUILD django-otp-0.9.1.ebuild 802 BLAKE2B 72eb8645f292fc55bb581e512cdfb51171b1a449e2767c717bf303906bab2bb7b71c11cc86b7227c19a55f0da45b6dbd897e1cfcf74649b4713b429f0fec7dbf SHA512 7b36b987c0c6f0144458b0b9d98cababde280f6fd0f4f04483decad56a1260444fce91c20b654e9e9987e7d88e2e375ba18b6ddac3ba43b2f218883e8a1d9074
+EBUILD django-otp-0.9.2.ebuild 839 BLAKE2B 450434a0df280094bb855c2bc6109b9080a95f36e76ce1d881acabfa72c65bc261e35daba69262c33a9c4482dcd79f5c2b0a2fefe8ef2615524ac2e69f40411d SHA512 822577452adcead3039eef453c11060c679dc22063a2f51f5326dfbcd105dfb621dbf63a5fc4ba3a42f137e34b63298fe3ffb029e22a152a1e6c6ab086beb8bb
MISC metadata.xml 386 BLAKE2B 089280b44d70d41d6ac97b035d5346c7e484d53cb5cc4505a1953d46c2a618140fbc1a3094a14ef18d3c39023ae10b7d162977537b646563459f3a9912e765fe SHA512 6d181b8eaad8df98a615d06c292284c1f8fe28e6bbfbd467428fc387fb9553221646d2014a10c3d16a4613db7d6f0af75714dacacecf1daad0db053d08deb3e1
diff --git a/dev-python/django-otp/django-otp-0.9.2.ebuild b/dev-python/django-otp/django-otp-0.9.2.ebuild
new file mode 100644
index 000000000000..b14eef63539e
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}