summaryrefslogtreecommitdiff
path: root/dev-python/django-otp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-python/django-otp
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest2
-rw-r--r--dev-python/django-otp/django-otp-1.0.4.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 9053bc818ea9..aa866968648b 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,5 +1,7 @@
DIST django-otp-1.0.2.gh.tar.gz 66885 BLAKE2B be98b68f0aa5df25835afa28a23d25e0353dc2d556e62bdf1610a44a409a8e48422e17f274b21eb7cbd421cc4a25a35d01e5d7b3bd99d9caec8c8060da26f57a SHA512 6fe7f79858bdf362dd35e1aeb87c086edd5daf17d4429fc4cb39f3d287ee4c7cf8fb2d6d8f6a7d1b4606104d6732a705b9285f9fec93e4e7c7ca3f3f52541ddd
DIST django-otp-1.0.3.gh.tar.gz 67007 BLAKE2B 33aed04898afb6ad3940e06436a1d2b4b9349e8fcd55acba0719084939fb9b111e0c266f4964826491f91f832c16f2e4d505486016bfad416706e3e7ef6f3f37 SHA512 7b661228377fa57812a45888e415478cee49d1e343cbc814ba8631f4c354077901ec82f79e69abd00c6bad1dffa026d3e03f4cf0809b074ae1e02ab2cf878137
+DIST django-otp-1.0.4.gh.tar.gz 68976 BLAKE2B 30908c3769ca9c05c850524d8a3b155f7ac8fcfa8e69073622d83808d7b78293604f9b332e59b074a6737188ca4f53ede13d31d283588605ca17f994bf5d4e5e SHA512 7b37fbc56a708f5c26e6204fba344235c7823db66d7e3e56b74516efc8a1de4150c088ce2d94c04c10855f438b077599d361a4d2c2263e8ff2936309dc0ddb6e
EBUILD django-otp-1.0.2.ebuild 879 BLAKE2B afe469a99ffafd9ddfefd04709b6209380459ab1f0e2ab0ea8335bed19f4c6ca30930efd0a71e1f1e3bf676ac6846d2634dd550e54b4d973ab3b47e99e30fdfe SHA512 b8fa48d607c6669660fbfd4c4705d389e9ef2218571ec90438df9c6704a0744b06ca64fa9d810df7c186c137dbda600cd2ecb00a2fd912c59acf2f9cc760f9b5
EBUILD django-otp-1.0.3.ebuild 879 BLAKE2B aa0f40028ac48510140cd533194ed3fc34ce29d574c7cf41e93752d243d87acd9b604d58d1add09003a2dfc5b184061d848b2589cfbf667bdd1abb6dbcb12718 SHA512 068e1d44bf9b4774505f607b31aa7ed570548de1dcb5b9afe3fc0927d4aca3c4bca28fd3ab8f834acb38f37af9ef558bd75ecb82f4a5ab77a42e2a21425c86ed
+EBUILD django-otp-1.0.4.ebuild 879 BLAKE2B aa0f40028ac48510140cd533194ed3fc34ce29d574c7cf41e93752d243d87acd9b604d58d1add09003a2dfc5b184061d848b2589cfbf667bdd1abb6dbcb12718 SHA512 068e1d44bf9b4774505f607b31aa7ed570548de1dcb5b9afe3fc0927d4aca3c4bca28fd3ab8f834acb38f37af9ef558bd75ecb82f4a5ab77a42e2a21425c86ed
MISC metadata.xml 386 BLAKE2B 089280b44d70d41d6ac97b035d5346c7e484d53cb5cc4505a1953d46c2a618140fbc1a3094a14ef18d3c39023ae10b7d162977537b646563459f3a9912e765fe SHA512 6d181b8eaad8df98a615d06c292284c1f8fe28e6bbfbd467428fc387fb9553221646d2014a10c3d16a4613db7d6f0af75714dacacecf1daad0db053d08deb3e1
diff --git a/dev-python/django-otp/django-otp-1.0.4.ebuild b/dev-python/django-otp/django-otp-1.0.4.ebuild
new file mode 100644
index 000000000000..26c9a4b8f2af
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}