summaryrefslogtreecommitdiff
path: root/dev-python/django-otp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
commit02930d1eb5af78d32b1597af6af24163895d9e0f (patch)
tree7908188ca5a80d7ff557ebc70fe3bdcbf2875832 /dev-python/django-otp
parent54654470d999265b5a0010be7190e8a9993b1840 (diff)
gentoo auto-resync : 11:05:2023 - 23:47:37
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest2
-rw-r--r--dev-python/django-otp/django-otp-1.2.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index bf1502ab3f8a..99dcf9518420 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,3 +1,5 @@
DIST django-otp-1.1.6.gh.tar.gz 76790 BLAKE2B 442c2418a870ccc8034a080415befb09780f9228562a15737e0911a0343945908f9fc2e026220a4477a5e5e1a6c1e4c3f7d51c823d4a9019f2bc15ae3367d8a3 SHA512 58c64651a5b274542bf09604daf3e59fdb0ea4eb96e7d14e59fd10a042d86cffb5df462191198f12320ea706f4d9aa651ef2c79ad7aa33e9d4ba0d157d90f4fb
+DIST django_otp-1.2.0.tar.gz 64888 BLAKE2B 4b9eff29508b1ce537452ecf7337c7440acbab08b66c651080973d6a39e8e7cd5255f440e4dfb397886f562234d297333eee296ee9958075790e183e47e6637a SHA512 2f108ff08a01044a0f6572f4e5a57311c28926b5baf808f5013e6ffc1e40db77fd182b078ce53596b4ecee87fc0223fdf6fc41158e03a6ba3e80455234d64810
EBUILD django-otp-1.1.6.ebuild 968 BLAKE2B 31df4f4a70a81c7a3e2fbf310662bccf7046dcbe81315c6186216451624f11c5f75a8412b033b0f3873717c23f4117596d59cef65a41d9a60755a6fbff8e482e SHA512 21b01e9fbd5825dc225195d466a09c372efb4885cd9cc59e306fc52f19d5941fe14a83d5e35874ef6432cbca809a8421bae0d5a32ccf07144d56c2225c2b769d
+EBUILD django-otp-1.2.0.ebuild 954 BLAKE2B 90a2c23f82e2cd0eba9ac159549b0c94cca518244eac161efd185368a4fcf4e841e63b33139ff074439a160ed3ce32b7fb9661d9d07939b2335f937b707cc133 SHA512 a7848266574d2fb8cf68d529ffa2128ece9f80dea42de4cec8f00883a31ea304b60bcff3c39d73bddce1c2b2ecce93bb14bd53991a1dc924a1735ce636ebfdf8
MISC metadata.xml 387 BLAKE2B f1be13d8af9a4926d7c82442cb939f1030a8234d4f18917cf8b2b8b204d763974b5f08f8597334238733d6446fc1165ba19d454e13105dc16afacf1fa3a98ea0 SHA512 d85060b9982c55057128a0c7b7fd1537e3eb613f9d44e6c40438283d76f6d65c92db78815005ce44b4096d57c62584659d5997491f003ca1ed8c36f88db8623c
diff --git a/dev-python/django-otp/django-otp-1.2.0.ebuild b/dev-python/django-otp/django-otp-1.2.0.ebuild
new file mode 100644
index 000000000000..f785275f25f3
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}