summaryrefslogtreecommitdiff
path: root/dev-python/django-otp/django-otp-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-09 10:28:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-09 10:28:50 +0000
commit91b873ea3e20149dbb554dc214611efa4627962a (patch)
tree46c9be7cf8a9fa2923fc9c220e10eabde601842d /dev-python/django-otp/django-otp-1.3.0.ebuild
parent70b888182faea1598e1b5e231078af492793858a (diff)
gentoo auto-resync : 09:11:2023 - 10:28:50
Diffstat (limited to 'dev-python/django-otp/django-otp-1.3.0.ebuild')
-rw-r--r--dev-python/django-otp/django-otp-1.3.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-otp/django-otp-1.3.0.ebuild b/dev-python/django-otp/django-otp-1.3.0.ebuild
new file mode 100644
index 000000000000..a7fd6fe4a416
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}