summaryrefslogtreecommitdiff
path: root/dev-python/django-oauth-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/django-oauth-plus
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-oauth-plus')
-rw-r--r--dev-python/django-oauth-plus/Manifest3
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild34
-rw-r--r--dev-python/django-oauth-plus/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/django-oauth-plus/Manifest b/dev-python/django-oauth-plus/Manifest
new file mode 100644
index 000000000000..3a0878a716cb
--- /dev/null
+++ b/dev-python/django-oauth-plus/Manifest
@@ -0,0 +1,3 @@
+DIST django-oauth-plus-2.2.8.tar.gz 25911 BLAKE2B 5356257f2d95fafe40ae8d65e7baf5ca8b3b7269151acb81dc5eac74fd1bdb97100a916fd406a4116ba2df0b6c0f44f561abefcfb059cc1520291d04eab5a66b SHA512 9237a2e2e52923b2fdfd3b7feff63e11f2c06c871faca3455189edba233e2a6513169481092f413c3ddea1c919f4b995fb465a505935388f1d803d094942ee07
+EBUILD django-oauth-plus-2.2.8.ebuild 922 BLAKE2B 80116d95a7ec9d8a6804d8a322bacce1b9784028da5ef0e0caab9a9606da0f2dd63b17e5f94ca66030ff36ff5ea4a6f263317719a8b63c056652eb9c455ecdbc SHA512 5143f91acda1d75b293fd1077aab6a87ec2dca97f7546c029b7ab349311320f72044920d6da07c85868b9bda05dfe0eb39f019ad3de5cd39c849d766578d5e62
+MISC metadata.xml 320 BLAKE2B 5b0abaaa21ff82ce24003879834e0b77cdd6701e3665d79f06d2a21594c5f50cab033628ad7ef8fcbb2eb6aa387b96f569b4eaf2b3785aa7482da4d064bcbeff SHA512 c5ca167dfd305e47ddff6d68b5d473ec4c98cd869eba30148fd3cb82dd7d105717a70d5e50f519263c8fbac5e41108041df1ce972406262b170aeb2414406eb8
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild
new file mode 100644
index 000000000000..3ac3f880ea8d
--- /dev/null
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+# Testsuite written for py2 only, no indication given in source
+
+inherit distutils-r1
+
+DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
+HOMEPAGE="https://pypi.org/project/django-oauth-plus/ http://code.welldev.org/django-oauth-plus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/django-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ PYTHONPATH=.:oauth_provider
+ if "${PYTHON}" oauth_provider/runtests/runtests.py; then
+ einfo "Testsuite passed under ${EPYTHON}"
+ else
+ die "Testsuite failed under ${EPYTHON}"
+ fi
+}
diff --git a/dev-python/django-oauth-plus/metadata.xml b/dev-python/django-oauth-plus/metadata.xml
new file mode 100644
index 000000000000..5d603775593c
--- /dev/null
+++ b/dev-python/django-oauth-plus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-oauth-plus</remote-id>
+ </upstream>
+</pkgmetadata>