summaryrefslogtreecommitdiff
path: root/dev-python/django-oauth-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/django-oauth-plus
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/django-oauth-plus')
-rw-r--r--dev-python/django-oauth-plus/Manifest5
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild34
-rw-r--r--dev-python/django-oauth-plus/metadata.xml11
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/django-oauth-plus/Manifest b/dev-python/django-oauth-plus/Manifest
new file mode 100644
index 000000000000..3b1050b3eb8f
--- /dev/null
+++ b/dev-python/django-oauth-plus/Manifest
@@ -0,0 +1,5 @@
+DIST django-oauth-plus-2.2.8.tar.gz 25911 SHA256 a9b08d846e23ce0227de8ccce72d453d3618a3de4f83959da2ae75f76b627867 SHA512 9237a2e2e52923b2fdfd3b7feff63e11f2c06c871faca3455189edba233e2a6513169481092f413c3ddea1c919f4b995fb465a505935388f1d803d094942ee07 WHIRLPOOL 9bf83c5052314cc1174ba4080653992569672a7c47a5b78896d7220b099346ac40e1a0f4c81738ec2638b76e942083953eb11e37925c2582cae5a5d098d49132
+EBUILD django-oauth-plus-2.2.8.ebuild 925 SHA256 dd7c6c26ab6275f5ec2d04fec826af9baf4bc4ce34886f703365d304d1ea9ab7 SHA512 35ad0ca8ea9ede21685a9f078f2365c1bd76bb90b3a5a6f9ff7cd6ded1bc4344358faad55362fcbdb0f3f8cea791b089f2008ce862a2f3a3b1e3916163e14e2f WHIRLPOOL 46fe79076105f24b9c2025d86b458a3f7da23022a1ad5ecc5aa11b5840494d7b0defc3b85166bdd7e295c20916d7a38928002251b5f952aa4a3cfd27c367110b
+MISC ChangeLog 2612 SHA256 849731c4fd3a83145c7fef24f85e99cb8635295cf4cd277369c7f4eca480303d SHA512 5f888b6ff34479892846dbac85eba77bd1d8186931b651c5b219f2e5dc1a783a795788812f88ebaa9e403371ef8a6466d4148faaf969624c342c8610d6c61fd7 WHIRLPOOL 810488e4faf410d8e51ab0dbe2c374ae1e972d7423e9730c6f62e111e5b3833dd5473a8abdad2723655c0b7c98021992451f3bee7ba1c46cab6a6f02f31c4541
+MISC ChangeLog-2015 2557 SHA256 04917aed5ca1844882c32d4c351bac6b3d7b6f8748c5d448e63e53d267642c5b SHA512 2fef7ffa366b696fe86ffdd10b3476fa5fe4fa3bfda69e44448a9ed1080b57e6827423843b501653f53fde8196ccc56060b99ff217515ff49dec0ee017d0616e WHIRLPOOL 63be1e92fc0c1b6197851e3bd090dfa5fe839e07fd682aca29a4ffc3adbb731465b977bdc51c9c4bb3918ee96425c182e1c1db20230d8b546a0dc046cfc3dca5
+MISC metadata.xml 320 SHA256 203446184d39edc8a59ce9848f16a75b6fdb65ac7cbda485db36113ec81cea83 SHA512 c5ca167dfd305e47ddff6d68b5d473ec4c98cd869eba30148fd3cb82dd7d105717a70d5e50f519263c8fbac5e41108041df1ce972406262b170aeb2414406eb8 WHIRLPOOL 46e2fe76d1e2d37f880c4adc4857133a9e5dd4f98dd6e4c4dc849de956b9adadecfdd8be19b677b9767548b1fc1a62502ddda25f6f6bed70921dd1ade6fdd554
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild
new file mode 100644
index 000000000000..a3b9d827c509
--- /dev/null
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+# Testsuite written for py2 only, no indication given in source
+
+inherit distutils-r1
+
+DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
+HOMEPAGE="https://pypi.python.org/pypi/django-oauth-plus http://code.welldev.org/django-oauth-plus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/django-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ PYTHONPATH=.:oauth_provider
+ if "${PYTHON}" oauth_provider/runtests/runtests.py; then
+ einfo "Testsuite passed under ${EPYTHON}"
+ else
+ die "Testsuite failed under ${EPYTHON}"
+ fi
+}
diff --git a/dev-python/django-oauth-plus/metadata.xml b/dev-python/django-oauth-plus/metadata.xml
new file mode 100644
index 000000000000..5d603775593c
--- /dev/null
+++ b/dev-python/django-oauth-plus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-oauth-plus</remote-id>
+ </upstream>
+</pkgmetadata>