summaryrefslogtreecommitdiff
path: root/dev-python/django-mptt/django-mptt-0.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
commitb1c81de4fadbd00897700a7321f03b390d952b2e (patch)
treee6cc812351d4f105c110cfc363ebb497e996f47a /dev-python/django-mptt/django-mptt-0.13.1.ebuild
parent7c59acba5699c9c58090a7a738669669a7307023 (diff)
gentoo resync : 26.08.2021
Diffstat (limited to 'dev-python/django-mptt/django-mptt-0.13.1.ebuild')
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-mptt/django-mptt-0.13.1.ebuild b/dev-python/django-mptt/django-mptt-0.13.1.ebuild
new file mode 100644
index 000000000000..10262c58b326
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="utilities for modified preorder tree traversal and trees of model instances"
+HOMEPAGE="https://github.com/django-mptt/django-mptt"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}