summaryrefslogtreecommitdiff
path: root/dev-python/django-js-asset
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 20:02:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 20:02:26 +0000
commit0da5c40f264673f79a9d8c95d465d1cab718d282 (patch)
treecf498476cd0085b71f73a02d2570c770c9023337 /dev-python/django-js-asset
parentdfa2037f41649c9775d690a3d01cfd5cabf4db71 (diff)
gentoo auto-resync : 15:02:2023 - 20:02:26
Diffstat (limited to 'dev-python/django-js-asset')
-rw-r--r--dev-python/django-js-asset/Manifest4
-rw-r--r--dev-python/django-js-asset/django-js-asset-2.0.ebuild20
-rw-r--r--dev-python/django-js-asset/metadata.xml7
3 files changed, 23 insertions, 8 deletions
diff --git a/dev-python/django-js-asset/Manifest b/dev-python/django-js-asset/Manifest
index 13af49f360d3..4da25257c0b9 100644
--- a/dev-python/django-js-asset/Manifest
+++ b/dev-python/django-js-asset/Manifest
@@ -1,3 +1,3 @@
DIST django-js-asset-2.0.gh.tar.gz 7386 BLAKE2B 5bebddc68a6d77b9ffc4c685cfcf0c34d03a82d1f24ea0bc64f35e70bf3a736fc8be612fba1e21bfbe1cb646363f06d0d001822209e15034cb03c337c80d24fd SHA512 0ec4954952394d90946d0653e86ecf45eb83ceaeb99bfde1eeed68f471110b85260abd7ae69f5b2c318e4341c09fd31efb781825d74164dc8ac6bd94bcb6f8e7
-EBUILD django-js-asset-2.0.ebuild 754 BLAKE2B 14fc3aab43df55a49e36641baa5b743e246319522022a2d80521d383cb72c96dbe2a96f4fc6ad6b543d60bad321a9959ee4167abc0b5dc68e4c2eaf4e915ffb2 SHA512 3618a1975153f2e19aae29fa44a52c6d2a2d32e737596b450961be0b0ad1c4568697565f9c64a0a192100fd4c8d8693df14e97fb5c469ae71b710e81f9ace252
-MISC metadata.xml 246 BLAKE2B bbeaabf225f3b131a4c28d6f20d9ff944642645041d0f9a257ef05e2f1865b1c76c465b7769b7142285d25b77107999d719d73f75db841eb92b92b39d5f7a1c9 SHA512 abb5f9c6ef30b9cc55e01db0aa0093ff146eae298d3b9348226d9835b39e040b6096bc2ac7fa8ae74c55fa94e83f706ae3d2b3b755ed31c8222eb29748c0a8ac
+EBUILD django-js-asset-2.0.ebuild 811 BLAKE2B f85fe540e8e2f071cf41f18cc58b6461ee712c9b0ea259ac82dc2b51047e32f29ae6937477e249a12bc8ef05da8d28e433aaa85fe2db2bb01b33293a6b264325 SHA512 cf22743afe24628d051de506661b4041c882bc20ed011a1d987b99e116d854571bbc66208f0487bba708df00d9058d1e7ef6214c7207cbc515595d973f86a05a
+MISC metadata.xml 408 BLAKE2B c8db9d533cb5e50da5e8e78232d7723f4fba34aae72887329e3f80b6022446ccefd842d21b47a72c76f0801afc095f066a324b17f13586e66d8d091f4e824d42 SHA512 3b4dc889011addf71fd0326368315a22b639ac0b3397175e6e3bc0f2ae031290c0b3f06387c81609d2f0005ba9439ceff4382b4e7df834902f87a3678657ac44
diff --git a/dev-python/django-js-asset/django-js-asset-2.0.ebuild b/dev-python/django-js-asset/django-js-asset-2.0.ebuild
index 8eb1953daefe..6654e3521448 100644
--- a/dev-python/django-js-asset/django-js-asset-2.0.ebuild
+++ b/dev-python/django-js-asset/django-js-asset-2.0.ebuild
@@ -4,11 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
+
inherit distutils-r1
-DESCRIPTION="script tag with additional attributes for django.forms.Media"
-HOMEPAGE="https://github.com/matthiask/django-js-asset"
+DESCRIPTION="Script tag with additional attributes for django.forms.Media"
+HOMEPAGE="
+ https://github.com/matthiask/django-js-asset/
+ https://pypi.org/project/django-js-asset/
+"
SRC_URI="
https://github.com/matthiask/django-js-asset/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -20,8 +24,14 @@ KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND=">=dev-python/django-2.2[${PYTHON_USEDEP}]"
-BDEPEND="test? ( ${RDEPEND} )"
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
python_test() {
cd tests || die
diff --git a/dev-python/django-js-asset/metadata.xml b/dev-python/django-js-asset/metadata.xml
index 039080e9bc24..fa3194cddf60 100644
--- a/dev-python/django-js-asset/metadata.xml
+++ b/dev-python/django-js-asset/metadata.xml
@@ -1,8 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
<upstream>
+ <remote-id type="github">matthiask/django-js-asset</remote-id>
<remote-id type="pypi">django-js-asset</remote-id>
</upstream>
</pkgmetadata>