summaryrefslogtreecommitdiff
path: root/dev-python/django-filter/django-filter-21.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/django-filter/django-filter-21.1-r2.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/django-filter/django-filter-21.1-r2.ebuild')
-rw-r--r--dev-python/django-filter/django-filter-21.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-filter/django-filter-21.1-r2.ebuild b/dev-python/django-filter/django-filter-21.1-r2.ebuild
new file mode 100644
index 000000000000..23b5fd509266
--- /dev/null
+++ b/dev-python/django-filter/django-filter-21.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django app allowing declarative dynamic QuerySet filtering from URL parameters"
+HOMEPAGE="https://github.com/carltongibson/django-filter"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/coreapi[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test-skipIf.patch
+)
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings
+ django-admin test -v 2 || die
+}