summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-26 17:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-26 17:40:44 +0000
commitfab95e98818bada1626a7723a1348f4e920d25e0 (patch)
tree8f2d17919a6a012a482e3ad069d44e54739c6249 /dev-python/django-debug-toolbar
parent533b7fe309e51c571ca6fe8fdd4453537d4f662a (diff)
gentoo auto-resync : 26:02:2024 - 17:40:44
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest3
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild38
-rw-r--r--dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch20
3 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index ce55faaeae63..eec7d8642081 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,6 +1,3 @@
-AUX django-debug-toolbar-4.2.0-py312.patch 750 BLAKE2B 0cad44cbdc2e0ede481e8e6b3f1e08e91b0c4e50a3bf67ab16b03255bf40dfd4ba8b9d0a12db0f1cd4b0e3ece91f6c41e1b134f7e370c94262af0d307dcd91fe SHA512 0c0ee4a99f93fb2f49569bef791cd92e45aa8c0e975366694823c0889037435e692b8f464fcd5e99eb9985acc5cde71f7679cb4bb15358d20d9da43c7b937a89
-DIST django_debug_toolbar-4.2.0.tar.gz 259709 BLAKE2B 81172bca569f6080710db2180650b0620670a4b4d2919d8b1694bf9f15425d9378f6cd0cbb852544fca0809388bb13867500a38c9046e1feaa241cde973936d9 SHA512 ff36d92132fd9338e88a2f078747c1e54e7633aecc6babea28ccb0c080b0beb99feccf1d1c00960ba109e3e6e4805562c36c6571842ea3baeda860c71ffcbd50
DIST django_debug_toolbar-4.3.0.tar.gz 261173 BLAKE2B d5332d205be3a08826ac8b1bf1cb1ed8cd06b66cd5efb203a4290c9e75aab96c822d46c93830182cf6bd6fe2b867e14d5a82d52f6f72aebeaa9aa8ff1bc4e558 SHA512 48e06187289fc92216e5d7c0a77f88ce2fd105eef5ae2bc8dd0d398929c86a9fe021ea1f88f03083174f846f7e43cd07353e1175694733bfa0d55e4aa612c7f3
-EBUILD django-debug-toolbar-4.2.0-r1.ebuild 757 BLAKE2B 691c7ebc7276ac956ef60293fe9e0a9d5889858da4ece4278e4b4d91e23c978aa2d0c319d591f7b74774201e93430220112355fee0baeb0e7a974174b55ab811 SHA512 b547e815a09e832442b163870ea758f1ff88fa81c118c81cddf794df36d0df29df844718198e7196d30656fc9a645a62061e53a368c7ed2603111e3ec3fa7152
EBUILD django-debug-toolbar-4.3.0.ebuild 718 BLAKE2B 7b1533c599d9cc3417fe03a4a399704dd2baead8863b98196c2873e7edf2a62d02a5233ac97a53b174aeed2579a658e85f77eab033451076734acbbcac840df5 SHA512 c3776e4893b148f3b73ebb8f42e7034c4f4ac82f798e1245c5b2bcbfed0d5c9c12a875b2cfe90c9f05c78c304e3a6e8de898247f622b94d73416b83c2f129032
MISC metadata.xml 400 BLAKE2B 5e173b9872626f2eb14b25d4b0271f339576fefc19a28f3ad8a8358bd0cd07ef6af0a268f7aa0f403ffb6ffd9527415bc173f7c5fb516bdb2e201883a8ec7390 SHA512 64e2fd8932cc6795a7d72aa37d8634f17556f1141c1bef1abddca2d56fa67f8500861b53a2698a96bf8adf66e7a991108b59fce55c710cd6cc3963ee3a35241e
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild
deleted file mode 100644
index 31ff14e414eb..000000000000
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A configurable set of panels that display various debug information"
-HOMEPAGE="
- https://github.com/jazzband/django-debug-toolbar/
- https://pypi.org/project/django-debug-toolbar/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/html5lib[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-py312.patch )
-
-python_test() {
- "${EPYTHON}" -m django test -v 2 --settings tests.settings \
- || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch b/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch
deleted file mode 100644
index 69a5558da31b..000000000000
--- a/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/tests/panels/test_profiling.py 2023-12-30 20:02:22.263807899 +0100
-+++ b/tests/panels/test_profiling.py 2023-12-30 20:03:44.655458186 +0100
-@@ -1,3 +1,6 @@
-+import sys
-+import unittest
-+
- from django.contrib.auth.models import User
- from django.db import IntegrityError, transaction
- from django.http import HttpResponse
-@@ -50,6 +53,10 @@
- self.assertNotIn("render", content)
- self.assertValidHTML(content)
-
-+ @unittest.skipUnless(
-+ sys.version_info < (3, 12, 0),
-+ "Python 3.12 no longer contains a frame for list comprehensions.",
-+ )
- def test_listcomp_escaped(self):
- self._get_response = lambda request: listcomp_view(request)
- response = self.panel.process_request(self.request)