summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/django-debug-toolbar
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest2
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild21
2 files changed, 10 insertions, 13 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index d84a4fc78910..6e03e351d25c 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,3 +1,3 @@
DIST django-debug-toolbar-2.2.tar.gz 322475 BLAKE2B cff55a26f4d95353edff3d7f678a052c262636afc94307e22e4d9dc1b6bbe3c0bc1a4997c4904a397de97218b462d52e67ac0f80bb05de7736cb278c7dca58ee SHA512 5cd9e50852bd7efeb83879c5e9fe10fe6df5087b746e9cb2a0e13e66b3fe0a815a6eaea4b273258e7e682149bc29ad8979268d2be263539c522624e3f16aa5f5
-EBUILD django-debug-toolbar-2.2.ebuild 1368 BLAKE2B 7f075599c0db2cea461d893a80a382345835a40512be9f8ccc0336093c277afd4bb72de7730e84a02b72082495e8527d3d8eb993bd92f6604fe49eb67b706375 SHA512 8fc887526e125f289dc2aa9825ca84f6f66cf348ff38cd1fe8004ca469cad17d6f17ca8378b1191b7b3f42f922a787ff1b9abc5983c2b604b609ae4c44e83cb2
+EBUILD django-debug-toolbar-2.2.ebuild 1172 BLAKE2B c681f25cfd6881ec951ed1706e8901e666e76bcdfdaf9f791f32e87e81efa57464b5874503f33bf768628613896a667947872c7f75cc0da33fce7cf72e87b074 SHA512 19e61bd2944a8ec95a829d9f2b46c87e29f589a88a3c6efe1ddd12b9ea6098d540c1dafd6bb22e4653362a6f9879ea91375e73718f8dc40c21352211ae94badb
MISC metadata.xml 356 BLAKE2B c0d02bcf9ab38d7939a3edaf8eca080283ccee6f95f1e04ac96ce5870845e6a84d6672d6ac923c74d18c340326bca379691946aac7a51bdee8d6f4adcb45a50e SHA512 12686662e852b0283d2212f0db83c832c1248723a7cd751990e43b1641ddbad2cc2c71c17ac4704c01beec9a9366fc726504c10e9a9e56456b544a800cfa7847
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild
index 2874326eb203..ee772858946d 100644
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild
@@ -16,37 +16,34 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/django-1.11[${PYTHON_USEDEP}]
>=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
"
-python_prepare_all() {
- # Prevent non essential d'loading by intersphinx
- sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+distutils_enable_sphinx docs
+python_prepare_all() {
# This prevents distutils from installing 'tests' package, rm magic no more needed
sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
distutils-r1_python_prepare_all
}
-python_compile_all() {
- use doc && emake -C docs html
-}
-
python_test() {
emake test
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
if use examples; then
docinto examples
dodoc -r example/.