summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-python/django-debug-toolbar
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest2
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-1.11.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 4bd9c1199509..eb2a110d3398 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,3 +1,5 @@
+DIST django-debug-toolbar-1.11.tar.gz 321727 BLAKE2B 89eab65bc0306da9fd81affbffc312eb99d04f19c66d9e5c6016df323a987e1b3fe1d177d409d68548aede869ed6d3e71adb5f4f4e5cb85a9ab431eca5664033 SHA512 8085b02fc25571e7b3bff02ff2bda8bec81a6000c6ed9e2aea10ec45eb1a3e5adf2ee95fcfbb0a11660fd716ebf2e35a9bdefbaf767b4afc732368a197857e62
DIST django-debug-toolbar-1.5.tar.gz 315928 BLAKE2B 8dde3c655baa6bd5f3b5d3ae0ba57b8c5746fc41bcfae9f506ad5c49ff64cdb51f0b9d67ee42695f884493cf21bd76fdcf943d88d97641b5d804d54c59163562 SHA512 9a421b80016bdaee8dd3ba2a9b7c3b788b54a4f464cdd5697e36536268e4d3d926bf77088a715e87f192dc8a20a100d8adac68c9c26a1191a5343e377240bf64
+EBUILD django-debug-toolbar-1.11.ebuild 1318 BLAKE2B 32be3662dd3873e5169f3e4615b21a9574883a0e3d5c5cd24f7827ab4612e0d2402b4d70b104d648ba7564e9e4d7b0fa51e09a6efab9e1709c269d267a32df8d SHA512 3f249a51f9bd3e91fdad3e96ec7fd88bd2cb0ea2503e72091adbeb07f0523c9672128cc23c419c8830402a40a5b3b5b1771d44d3356a0d5205cf8f5d77bfd1ac
EBUILD django-debug-toolbar-1.5.ebuild 1318 BLAKE2B 120586a6897ac11e76e0e796955df8dce5edc3dfa092e24b9be1dca6b5ef3db9523c4ae767e511699e9c95f1a0e2114a1217c50fa0bc51910ed0507a4a190b30 SHA512 543abc477ffb68d584ef125c28dc59b8f18991366fe5da69f034b6a0584845b088b78c7bc93805f81bdf453b67de992b24afbad58b073daf9750a424ee668880
MISC metadata.xml 356 BLAKE2B c0d02bcf9ab38d7939a3edaf8eca080283ccee6f95f1e04ac96ce5870845e6a84d6672d6ac923c74d18c340326bca379691946aac7a51bdee8d6f4adcb45a50e SHA512 12686662e852b0283d2212f0db83c832c1248723a7cd751990e43b1641ddbad2cc2c71c17ac4704c01beec9a9366fc726504c10e9a9e56456b544a800cfa7847
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-1.11.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-1.11.ebuild
new file mode 100644
index 000000000000..08bd4b0acde5
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-1.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/django-debug-toolbar/django-debug-toolbar/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.0[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # Prevent non essential d'loading by intersphinx
+ sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+
+ # This prevents distutils from installing 'tests' package, rm magic no more needed
+ sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}